ports/math/algae/files/patch-src-Makefile.in
Tijl Coosemans 3f80fdea42 - USES=fortran (eliminate FORTRANLIBS, LDFLAGS and pre-configure).
- Remove some patches and post-patch.
- Remove USE_AUTOTOOLS=autoconf and patch configure script directly.
- Replace BROKEN with BROKEN_${ARCH}.
- Staging (add DESTDIR support to the makefiles).
- Make sure the port uses its own arpack, blas, lapack and superlu.
2013-12-22 16:22:28 +00:00

24 lines
693 B
Text

--- src/Makefile.in.orig
+++ src/Makefile.in
@@ -48,7 +48,7 @@
# Libraries.
-LIBS = -L../arpack -larpack -L../superlu -lsuperlu @LOCAL_LIBS@ @LIBS@
+LIBS = ../arpack/libarpack.a ../superlu/libsuperlu.a @LOCAL_LIBS@ @LIBS@
# Source files.
@@ -218,9 +218,9 @@
# ========================== Installation ==========================
install: all
- $(INSTALL_PROGRAM) algae $(bindir)/algae-$(VERSION_NUMBER)
- rm -f $(bindir)/algae
- ln -s $(bindir)/algae-$(VERSION_NUMBER) $(bindir)/algae
+ $(INSTALL_PROGRAM) algae $(DESTDIR)$(bindir)/algae-$(VERSION_NUMBER)
+ rm -f $(DESTDIR)$(bindir)/algae
+ ln -s algae-$(VERSION_NUMBER) $(DESTDIR)$(bindir)/algae
.PHONY: install
uninstall: