ports/graphics/openexr-website-docs/files/patch-CMakeLists.txt
Matthias Andree 175bbab74c graphics/openexr*: upgrade to 3.3.0
This changes the ABI (but not the API) and .so file name,
so we will need to bump all PORTREVISIONs of users, and we'll also fix
graphics/ctl and multimedia/olive.

This is not going to be MFHd to 2024Q4 due to API change, and therefore
has also waited for 2024Q4 to branch before we committed this to main,
so as to avoid 2024Q4 breakage.

ChangeLog:	https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.3.0
PR:		281859
2024-10-13 15:54:20 +02:00

72 lines
2.5 KiB
Text

--- CMakeLists.txt.orig 2024-09-26 23:34:32 UTC
+++ CMakeLists.txt
@@ -63,8 +63,6 @@ include(cmake/OpenEXRSetup.cmake)
include(cmake/LibraryDefine.cmake)
include(cmake/OpenEXRSetup.cmake)
-add_subdirectory(cmake)
-message(STATUS "Configure ${OPENEXR_PACKAGE_NAME}, library API version: ${OPENEXR_LIB_VERSION}")
# Hint: This can be set to enable custom find_package
# search paths, probably best to set it when configuring
@@ -81,15 +79,6 @@ endif()
enable_testing()
endif()
-# Include these two modules without enable/disable options
-if (OPENEXR_BUILD_LIBS)
- add_subdirectory(src/lib)
-endif()
-
-if(OPENEXR_BUILD_TOOLS AND OPENEXR_BUILD_LIBS)
- add_subdirectory(src/bin)
-endif()
-
# Tell CMake where to find the OpenEXRConfig.cmake file. Makes it possible to call
# find_package(OpenEXR) in downstream projects
set(OpenEXR_DIR "${CMAKE_CURRENT_BINARY_DIR}/cmake" CACHE PATH "" FORCE)
@@ -97,10 +86,6 @@ file(WRITE "${CMAKE_CURRENT_BINARY_DIR}/cmake/OpenEXRT
# Can be empty since we already defined the targets in add_subdirectory
file(WRITE "${CMAKE_CURRENT_BINARY_DIR}/cmake/OpenEXRTargets.cmake" "# Dummy file")
-if(OPENEXR_BUILD_EXAMPLES AND OPENEXR_BUILD_LIBS)
- add_subdirectory( src/examples )
-endif()
-
# If you want to use ctest to configure, build and
# upload the results, cmake has builtin support for
# submitting to CDash, or any server who speaks the
@@ -123,33 +108,10 @@ endif()
#set(CTEST_DROP_SITE "open.cdash.org")
#set(CTEST_DROP_LOCATION "/submit.php?project=MyProject")
#set(CTEST_DROP_SITE_CDASH TRUE)
-include(CTest)
-if(BUILD_TESTING AND OPENEXR_BUILD_LIBS AND NOT OPENEXR_IS_SUBPROJECT)
- add_subdirectory(src/test)
-endif()
-
# Including this module will add a `clang-format` target to the build if
# the clang-format executable can be found. Only do this if we are top level
-if(NOT OPENEXR_IS_SUBPROJECT)
- include(cmake/clang-format.cmake)
-endif()
-
-option(OPENEXR_INSTALL_DOCS "Set ON to install tool manpages")
-if (OPENEXR_INSTALL_DOCS AND NOT OPENEXR_IS_SUBPROJECT)
- add_subdirectory(docs)
-endif()
-
option(BUILD_WEBSITE "Set ON to build website source")
if (BUILD_WEBSITE AND NOT OPENEXR_IS_SUBPROJECT)
add_subdirectory(website)
-endif()
-
-if (OPENEXR_BUILD_LIBS AND NOT OPENEXR_IS_SUBPROJECT)
- # Even if not building the website, still make sure the website example code compiles.
- add_subdirectory(website/src)
-endif()
-
-if (OPENEXR_BUILD_PYTHON AND OPENEXR_BUILD_LIBS AND NOT OPENEXR_IS_SUBPROJECT)
- add_subdirectory(src/wrappers/python)
endif()