ports/devel/json-c/files/patch-CMakeLists.txt
Sunpoet Po-Chuan Hsieh 5835907cca Update r551672
Use a patch file instead doing it in configure stage.

PR:		249412

Submitted by:	sunpoet (myself)
Tested by:	leres
2020-10-10 07:44:14 +00:00

13 lines
492 B
Text

Avoid use of newlocale(3) that results in increasing memory usage
--- CMakeLists.txt.orig 2020-07-26 15:08:19 UTC
+++ CMakeLists.txt
@@ -177,7 +177,7 @@ if (HAVE_STDLIB_H)
endif()
if (HAVE_LOCALE_H)
check_symbol_exists(setlocale "locale.h" HAVE_SETLOCALE)
- check_symbol_exists(uselocale "locale.h" HAVE_USELOCALE)
+ # check_symbol_exists(uselocale "locale.h" HAVE_USELOCALE)
endif()
if (HAVE_STRINGS_H)
check_symbol_exists(strcasecmp "strings.h" HAVE_STRCASECMP)