mirror of
https://git.freebsd.org/ports.git
synced 2025-05-28 17:06:32 -04:00
* When using skip-innodb_doublewrite in my.cnf, a parallel doublewrite buffer is still created. Bugs fixed #3411. * During a binlogging replication event, if the master crashes after the multi-threaded slave has begun copying to the slave’s relay log and before the process has completed, a STOP SLAVE on the slave takes longer than expected. Bug fixed #5824. * If pam_krb5 is configured to allow the user to change their password, and the password expired, the server crashed after receiving the new password. Bug fixed #6023. - Provide LibreSSL support [2] - Take maintainership. feld@ didn't pet the ports for almost two years, all updates was committed with maintainer timeout PR: 242649 Submitted by: Igor Zabelin [1]. fluffy@ [2] Approved by: maintainer (feld@, timeout >2 weeks)
29 lines
1.1 KiB
Text
29 lines
1.1 KiB
Text
--- libmysql/CMakeLists.txt.orig 2018-03-09 22:41:36 UTC
|
|
+++ libmysql/CMakeLists.txt
|
|
@@ -235,7 +235,7 @@
|
|
ADD_SUBDIRECTORY(authentication_ldap)
|
|
|
|
# Merge several convenience libraries into one big perconaserverclient
|
|
-MERGE_CONVENIENCE_LIBRARIES(perconaserverclient ${LIBS_TO_MERGE} COMPONENT Development)
|
|
+MERGE_CONVENIENCE_LIBRARIES(perconaserverclient ${LIBS_TO_MERGE} COMPONENT Development SKIP_INSTALL)
|
|
TARGET_LINK_LIBRARIES(perconaserverclient ${LIBS_TO_LINK})
|
|
|
|
# Visual Studio users need debug static library for debug projects
|
|
@@ -271,7 +271,8 @@
|
|
# and link them together into shared library.
|
|
MERGE_LIBRARIES_SHARED(libmysql ${LIBS_TO_MERGE}
|
|
EXPORTS ${CLIENT_API_FUNCTIONS} ${CLIENT_API_FUNCTIONS_UNDOCUMENTED}
|
|
- COMPONENT SharedLibraries)
|
|
+ COMPONENT SharedLibraries SKIP_INSTALL)
|
|
TARGET_LINK_LIBRARIES(libmysql ${LIBS_TO_LINK})
|
|
+IF(FALSE)
|
|
IF(UNIX)
|
|
# libtool compatability
|
|
@@ -327,6 +328,7 @@
|
|
# to initialize api_calls[] array in api_test.c
|
|
#
|
|
SET(CLIENT_API_FUNCTION_LIST "")
|
|
+ENDIF()
|
|
FOREACH(api ${CLIENT_API_FUNCTIONS})
|
|
SET(CLIENT_API_FUNCTION_LIST "${CLIENT_API_FUNCTION_LIST} ${api},")
|
|
ENDFOREACH()
|