mirror of
https://git.freebsd.org/ports.git
synced 2025-05-02 11:36:40 -04:00
The filesystems category houses file systems and file system utilities. It is added mainly to turn the sysutils/fusefs-* pseudo-category into a proper one, but is also useful for the sundry of other file systems related ports found in the tree. Ports that seem like they belong there are moved to the new category. Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are not moved as they currently don't fetch and don't have TIMESTAMP set in their distinfo, but that is required to be able to push a rename of the port by the pre-receive hook. Approved by: portmgr (rene) Reviewed by: mat Pull Request: https://github.com/freebsd/freebsd-ports/pull/302 PR: 281988
41 lines
1.3 KiB
Rust
41 lines
1.3 KiB
Rust
Unbreak on i386
|
|
|
|
error[E0308]: mismatched types
|
|
--> src/nodes/conv.rs:72:19
|
|
|
|
|
72 | Timespec::new(val.tv_sec() as sys::time::time_t, usec)
|
|
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ expected i64, found i32
|
|
|
|
--- src/nodes/conv.rs.orig 2020-04-20 18:46:46 UTC
|
|
+++ src/nodes/conv.rs
|
|
@@ -69,7 +69,7 @@ pub fn timeval_to_timespec(val: sys::time::TimeVal) ->
|
|
} else {
|
|
val.tv_usec() as i32
|
|
};
|
|
- Timespec::new(val.tv_sec() as sys::time::time_t, usec)
|
|
+ Timespec::new((val.tv_sec() as sys::time::time_t).into(), usec)
|
|
}
|
|
|
|
/// Converts a `sys::time::TimeVal` object into a `sys::time::TimeSpec`.
|
|
@@ -328,6 +328,10 @@ mod tests {
|
|
// modified and may not be queryable, so stub them out.
|
|
attr.ctime = BAD_TIME;
|
|
attr.crtime = BAD_TIME;
|
|
+ // Ignore rdev too
|
|
+ attr.rdev = 0;
|
|
+ // XXX: gid is always 0 when the tests run on tmpfs(5)
|
|
+ attr.gid = exp_attr.gid;
|
|
assert!(fileattrs_eq(&exp_attr, &attr));
|
|
}
|
|
|
|
@@ -365,6 +369,10 @@ mod tests {
|
|
// modified and may not be queryable, so stub them out.
|
|
attr.ctime = BAD_TIME;
|
|
attr.crtime = BAD_TIME;
|
|
+ // Ignore rdev too
|
|
+ attr.rdev = 0;
|
|
+ // XXX: gid is always 0 when the tests run on tmpfs(5)
|
|
+ attr.gid = exp_attr.gid;
|
|
assert!(fileattrs_eq(&exp_attr, &attr));
|
|
}
|
|
|