mirror of
https://git.freebsd.org/ports.git
synced 2025-05-05 16:07:38 -04:00
The module wasn't linked correctly with libmaxminddb.so when using `AP_FAST_BUILD`, because of not having correct ld-flags. Switch to default build (with a patch) solves the problem. Reported by: ler Sponsored by: The FreeBSD Foundation
21 lines
694 B
Text
21 lines
694 B
Text
--- src/Makefile.am.orig 2016-10-19 20:07:32 UTC
|
|
+++ src/Makefile.am
|
|
@@ -1,15 +1,16 @@
|
|
AUTOMAKE_OPTIONS = foreign
|
|
WC=-Wc,"$(CFLAGS)"
|
|
+WL=-Wl,"$(LDFLAGS)"
|
|
|
|
# the default target
|
|
all: module
|
|
|
|
# compile the DSO file
|
|
module: mod_maxminddb.c $(TARGET)
|
|
- $(APXS) -c $(LDFLAGS) $(LIBMAXMINDDB_LDFLAGS) $(LIBS) $(WC) $(APXS_LDFLAGS) mod_maxminddb.c
|
|
+ $(APXS) -c $(WL) $(LIBMAXMINDDB_LDFLAGS) $(LIBS) $(WC) $(APXS_LDFLAGS) mod_maxminddb.c
|
|
|
|
install-exec-local: module
|
|
- $(APXS) -i -a -n maxminddb .libs/mod_maxminddb.so
|
|
+ $(APXS) -S LIBEXECDIR=%%LIBEXECDEST%% -i -a -n maxminddb mod_maxminddb.la ### maxminddb .libs/mod_maxminddb.so
|
|
|
|
CLEANFILES= *.la *.lo *.o *.so *.slo .libs/*
|
|
|