ports/misc/py-onnx/files/patch-CMakeLists.txt
2025-02-25 19:36:49 -08:00

19 lines
1.2 KiB
Text

- use downloaded protobuf-22.3
--- CMakeLists.txt.orig 2024-09-30 20:12:15 UTC
+++ CMakeLists.txt
@@ -18,12 +18,12 @@ option(ONNX_USE_PROTOBUF_SHARED_LIBS "Build ONNX using
project(onnx C CXX)
option(ONNX_USE_PROTOBUF_SHARED_LIBS "Build ONNX using protobuf shared library. Sets PROTOBUF_USE_DLLS CMAKE Flag and Protobuf_USE_STATIC_LIBS. " OFF)
-option(BUILD_ONNX_PYTHON "Build Python binaries" OFF)
+option(BUILD_ONNX_PYTHON "Build Python binaries" ON)
option(ONNX_GEN_PB_TYPE_STUBS "Generate protobuf python type stubs" ON)
option(ONNX_WERROR "Build with Werror" OFF)
option(ONNX_COVERAGE "Build with coverage instrumentation" OFF)
option(ONNX_BUILD_TESTS "Build ONNX C++ APIs Tests" OFF)
-option(ONNX_USE_LITE_PROTO "Use lite protobuf instead of full." OFF)
+option(ONNX_USE_LITE_PROTO "Use lite protobuf instead of full." ON) # workaround for the failure, see https://github.com/onnx/optimizer/issues/38#issuecomment-817058821
option(ONNX_DISABLE_EXCEPTIONS "Disable exception handling." OFF)
option(ONNX_DISABLE_STATIC_REGISTRATION "Disable static registration for onnx operator schemas." OFF)
option(ONNX_USE_UNITY_BUILD "Enable Unity (Jumbo) build for" OFF)