mirror of
https://git.freebsd.org/ports.git
synced 2025-04-30 02:26:38 -04:00
102 lines
2.2 KiB
Text
102 lines
2.2 KiB
Text
--- tests/examples/meson.build.orig 2025-03-11 20:14:44 UTC
|
|
+++ tests/examples/meson.build
|
|
@@ -1,27 +1,75 @@
|
|
-subdir('audiomixmatrix')
|
|
-subdir('avsamplesink')
|
|
-subdir('camerabin2')
|
|
-subdir('codecparsers')
|
|
-subdir('codecs')
|
|
-subdir('cuda')
|
|
-subdir('d3d11')
|
|
-subdir('d3d12')
|
|
-subdir('directfb')
|
|
-subdir('gtk')
|
|
-subdir('ipcpipeline')
|
|
-subdir('mediafoundation')
|
|
-subdir('mpegts')
|
|
-subdir('msdk')
|
|
-subdir('mxf')
|
|
-subdir('nvcodec')
|
|
-subdir('opencv', if_found: opencv_dep)
|
|
-subdir('qsv')
|
|
-subdir('qt6d3d11')
|
|
-subdir('uvch264')
|
|
-subdir('va')
|
|
-subdir('waylandsink')
|
|
-subdir('webrtc')
|
|
-subdir('wpe')
|
|
+if get_option('audiomixmatrix').enabled()
|
|
+ subdir('audiomixmatrix')
|
|
+endif
|
|
+if get_option('applemedia').enabled()
|
|
+ subdir('avsamplesink')
|
|
+endif
|
|
+if get_option('camerabin2').enabled() and use_wayland
|
|
+ subdir('camerabin2', if_found: gtk_dep)
|
|
+endif
|
|
+if get_option('codecparsers').enabled()
|
|
+ subdir('codecparsers')
|
|
+endif
|
|
+if get_option('codecs').enabled()
|
|
+ subdir('codecs')
|
|
+endif
|
|
+if get_option('cuda').enabled()
|
|
+ subdir('cuda')
|
|
+endif
|
|
+if get_option('d3d11').enabled()
|
|
+ subdir('d3d11')
|
|
+endif
|
|
+if get_option('d3d12').enabled()
|
|
+ subdir('d3d12')
|
|
+endif
|
|
+if get_option('directfb').enabled()
|
|
+ subdir('directfb')
|
|
+endif
|
|
+if get_option('gtk3').enabled()
|
|
+ subdir('gtk')
|
|
+endif
|
|
+if get_option('ipcpipeline').enabled()
|
|
+ subdir('ipcpipeline')
|
|
+endif
|
|
+if get_option('mediafoundation').enabled()
|
|
+ subdir('mediafoundation')
|
|
+endif
|
|
+if get_option('mpegts').enabled()
|
|
+ subdir('mpegts')
|
|
+endif
|
|
+if get_option('msdk').enabled()
|
|
+ subdir('msdk')
|
|
+endif
|
|
+if get_option('mxf').enabled() and use_wayland
|
|
+ subdir('mxf', if_found: gtk_dep)
|
|
+endif
|
|
+if get_option('nvcodec').enabled()
|
|
+ subdir('nvcodec')
|
|
+endif
|
|
+if get_option('opencv').enabled()
|
|
+ subdir('opencv', if_found: opencv_dep)
|
|
+endif
|
|
+if get_option('qsv').enabled()
|
|
+ subdir('qsv')
|
|
+endif
|
|
+if get_option('qt6d3d11').enabled()
|
|
+ subdir('qt6d3d11')
|
|
+endif
|
|
+if get_option('uvch264').enabled()
|
|
+ subdir('uvch264')
|
|
+endif
|
|
+if get_option('va').enabled()
|
|
+ subdir('va')
|
|
+endif
|
|
+if get_option('wayland').enabled()
|
|
+ subdir('waylandsink')
|
|
+endif
|
|
+if get_option('webrtc').enabled()
|
|
+ subdir('webrtc')
|
|
+endif
|
|
+if get_option('wpe').enabled()
|
|
+ subdir('wpe')
|
|
+endif
|
|
|
|
executable('playout',
|
|
'playout.c',
|