mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
26 lines
821 B
Text
26 lines
821 B
Text
--- gst-libs/gst/va/meson.build.orig 2025-03-11 20:14:44 UTC
|
|
+++ gst-libs/gst/va/meson.build
|
|
@@ -54,12 +54,12 @@ extra_args = ['-DGST_USE_UNSTABLE_API',
|
|
'-DBUILDING_GST_VA',
|
|
'-DG_LOG_DOMAIN="GStreamer-VA"']
|
|
|
|
-if host_system not in ['linux', 'windows']
|
|
+if get_option('skip_gstva')
|
|
subdir_done()
|
|
endif
|
|
|
|
va_opt = get_option('va')
|
|
-if host_system == 'linux'
|
|
+if host_system in ['linux', 'freebsd']
|
|
msdk_opt = get_option('msdk')
|
|
qsv_opt = get_option('qsv')
|
|
if va_opt.disabled() and msdk_opt.disabled() and qsv_opt.disabled()
|
|
@@ -83,7 +83,7 @@ endif
|
|
subdir_done()
|
|
endif
|
|
|
|
-if host_system == 'linux'
|
|
+if host_system in ['linux', 'freebsd']
|
|
libva_drm_dep = dependency('libva-drm', version: libva_req, required: va_required)
|
|
if not libva_drm_dep.found()
|
|
subdir_done()
|