ports/sysutils/apcupsd/files/patch-src_cgi_Makefile
Alexey Dokuchaev 9221d550d0 - Enable SNMP driver by default due to popular demand [1]
- Rename option USB -> USB_DRV for consistency with other drivers and
  provide better option names while I'm here
- Remove hand-rolled `post-install' target now that @sample files are
  installed properly
- Reorder some knobs and drop CPPFLAGS/LIBS now that those seem to
  be detected correctly

PR:	215153 [1]
2017-03-07 10:21:01 +00:00

15 lines
730 B
Text

--- src/cgi/Makefile.orig 2014-11-04 19:17:43 UTC
+++ src/cgi/Makefile
@@ -43,9 +43,9 @@ install-cgi:
$(call INSTPROG,755,upsfstats.cgi,$(cgibin))
$(call INSTPROG,755,upsimage.cgi,$(cgibin))
$(call MKDIR,$(sysconfdir))
- $(call INSTNEW,644,apcupsd.css,$(sysconfdir))
- $(call INSTNEW,644,$(topdir)/platforms/etc/hosts.conf,$(sysconfdir))
- $(call INSTNEW,644,$(topdir)/platforms/etc/multimon.conf,$(sysconfdir))
+ $(call INSTDATA,644,apcupsd.css,$(sysconfdir)/apcupsd.css.sample)
+ $(call INSTDATA,644,$(topdir)/platforms/etc/hosts.conf,$(sysconfdir)/hosts.conf.sample)
+ $(call INSTDATA,644,$(topdir)/platforms/etc/multimon.conf,$(sysconfdir)/multimon.conf.sample)
uninstall-cgi:
$(call UNINST,$(cgibin)/multimon.cgi)