ports/net/libproxy/files/patch-CMakeLists.txt
Tobias C. Berner 58b7ce0b0c net/libproxy: update to 0.4.17
- mark libproxy-mozjs borken
- add new port for pacrunner
- drop support for python2

Changelog:
 - 0.4.16:
    * Port to, and require, SpiderMonkey 68
    * Use closesocket() instead of close() on Windows
    * Add symbol versions - be ready to introduce new APIs as needed
    * Add public px_proxy_factory_free_proxies function
    * Add PacRunner config backend (largely untested; feedback welcome!)
    * Small performance improvements
    * pxgsettings: use the correct syntax to connect to the changed signal (silences annoying output on console)
    * Support python3 up to version 3.9
    * Fix buffer overflow when PAC is enabled (CVE-2020-26154)
    * Rewrite url::recvline to be nonrecursive (CVE-2020-25219)
    * Remove nonfunctional and crashy pacrunner caching
    * Never use system libmodman (no other consumers, not maintained)
 - 0.4.17:
    * python bindings: fix "TypeError: argtypes must be a sequence of types" (#125)
2021-02-26 19:27:14 +00:00

31 lines
901 B
Text

As the library is only built in the master port, and therfore missing in the
build directory for the slave ports, find it via pkg-config and link against it,
when building a slave.
--- CMakeLists.txt.orig 2020-12-29 11:30:46 UTC
+++ CMakeLists.txt
@@ -26,6 +26,15 @@ else()
set(CMAKE_INSTALL_CONFIG_NAME ${CMAKE_BUILD_TYPE})
endif()
+# Make building the library optional.
+option(WITH_LIBRARY "Build libproxy.so" ON)
+
+if (NOT WITH_LIBRARY)
+ # For the other ports provide an easy way to link against libproxy.so via PkgConfig::LIBPROXY.
+ find_package(PkgConfig)
+ pkg_check_modules(LIBPROXY libproxy-1.0 REQUIRED IMPORTED_TARGET)
+endif ()
+
include(cmake/cpack.cmk)
include(cmake/ctest.cmk)
include(cmake/paths.cmk)
@@ -44,5 +53,7 @@ endif()
# Always build these
add_subdirectory(libproxy)
-add_subdirectory(utils)
+if (WITH_LIBRARY)
+ add_subdirectory(utils)
+endif()