mirror of
https://git.freebsd.org/ports.git
synced 2025-04-30 10:36:38 -04:00
Seems like the compiler got a whole lot stricter with this release. The biggest fix was changing the thread ID from unsigned long to pthread_t, which will probably break compilation on Win32. While we are at it, replace static uses of REINPLACE_CMD with patch files as per policy. This change is responsible for most of the newly added patches. The wzdftpd build scripts want to install plugins into ${PREFIX}/share when they belong into ${PREFIX}/lib. Instead of patching this in each Makefile.am, set --datadir=${PREFIX}/lib and work around the one file for which this is wrong. Approved by: eduardo (mentor) Differential Revision: https://reviews.freebsd.org/D38523
19 lines
654 B
Text
19 lines
654 B
Text
--- libwzd-perl/Makefile.am.orig 2006-06-13 07:34:54 UTC
|
|
+++ libwzd-perl/Makefile.am
|
|
@@ -7,14 +7,14 @@ ext: ext/Makefile ext/wzdftpd.pm ../libwzd/libwzd.la
|
|
cd ext && $(MAKE) LD_RUN_PATH=""
|
|
|
|
ext/Makefile: ext/Makefile.PL ext/wzdftpd.pm ext/wzdftpd.xs
|
|
- cd ext && $(PERL) Makefile.PL $(PERLFLAGS) $(PERL_MAKE_OPTIONS) INSTALLDIRS=vendor
|
|
+ cd ext && $(PERL) Makefile.PL $(PERLFLAGS) $(PERL_MAKE_OPTIONS) INSTALLPRIVLIB=${prefix}/lib
|
|
|
|
|
|
all-local: ext
|
|
|
|
install-data-local: all-local
|
|
echo "Installing wzdftpd.pm"; \
|
|
- cd ext && $(MAKE) install
|
|
+ cd ext && $(MAKE) pure_install
|
|
|
|
clean-local:
|
|
cd ext && test -f Makefile && $(MAKE) clean || true \
|