mirror of
https://git.freebsd.org/ports.git
synced 2025-05-02 19:46:41 -04:00
Strawberry is a developer friendly GraphQL library for Python, designed for modern development. * Type hints: Leverages Python type hints to provide a great developer experience while creating GraphQL Libraries. * Async Support: Supports async/await out of the box, allowing you to write your resolvers in a non-blocking way. * Extensible: Has support for schema and field extensions, allowing you to extend the schema with custom logic. * Generics: Supports generics, allowing you to create reusable types that can be used in multiple places. * Federation: Supports Federation, allowing you to create a federated GraphQL schema. * Dataloaders: Comes with support for dataloaders, allowing you to batch multiple queries into a single one. * Integrations: Has support for multiple integrations, allowing you to use it with your favorite web framework. https://github.com/strawberry-graphql/strawberry
15 lines
462 B
TOML
15 lines
462 B
TOML
Use the more lightweight build system "poetry-core".
|
|
|
|
--- pyproject.toml.orig 2024-03-24 18:49:43 UTC
|
|
+++ pyproject.toml
|
|
@@ -30,8 +30,8 @@ include = ["strawberry/py.typed"]
|
|
"Sponsor on Open Collective" = "https://opencollective.com/strawberry-graphql"
|
|
|
|
[build-system]
|
|
-requires = ["poetry>=0.12"]
|
|
-build-backend = "poetry.masonry.api"
|
|
+requires = ["poetry-core>=0.12"]
|
|
+build-backend = "poetry.core.masonry.api"
|
|
|
|
[tool.poetry.dependencies]
|
|
python = "^3.8"
|