mirror of
https://git.freebsd.org/ports.git
synced 2025-05-03 12:06:39 -04:00
Update to latest commit to support LLVM 15 Convert to CMake and adjust dependencies PR: 268745 Reviewed by: pkubaj, tcberner Tested by: pkubaj, brooks Approved by: portmgr (maintainer timeout, 2+ weeks)
16 lines
990 B
Text
16 lines
990 B
Text
--- CMakeLists.txt.orig 2022-09-27 05:17:27 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -116,11 +116,11 @@ if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU"
|
|
OR CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
|
|
# XXX figure out how to get "-std=c++11 -fno-rtti" from LLVM. That's how we
|
|
# get those options in the Automake path...
|
|
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -fno-rtti -fno-strict-aliasing -Wall -Wextra -Wno-long-long -Wno-unused-parameter -Wno-missing-field-initializers")
|
|
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-rtti -fno-strict-aliasing -Wall -Wextra -Wno-long-long -Wno-unused-parameter -Wno-missing-field-initializers")
|
|
if(SUPPORTS_FVISIBILITY_INLINES_HIDDEN_FLAG)
|
|
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
|
|
endif()
|
|
- set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O3")
|
|
+# set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O3")
|
|
endif()
|
|
|
|
###############################################################################
|