mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
32 lines
1.1 KiB
TOML
32 lines
1.1 KiB
TOML
--- pyproject.toml.orig 2025-04-10 04:12:24 UTC
|
|
+++ pyproject.toml
|
|
@@ -70,29 +70,6 @@ qats = "qats.cli:main"
|
|
[tool.poetry.scripts]
|
|
qats = "qats.cli:main"
|
|
|
|
-# enable dynamic versioning using Git tags
|
|
-# https://pypi.org/project/poetry-dynamic-versioning/
|
|
-[tool.poetry-dynamic-versioning]
|
|
-enable = true
|
|
-vcs = "git"
|
|
-format-jinja = """
|
|
- {%- if distance == 0 -%}
|
|
- {{ serialize_pep440(base, stage, revision) }}
|
|
- {%- elif revision is not none -%}
|
|
- {{ serialize_pep440(base, stage, revision + 1, dev=distance, metadata=[commit]) }}
|
|
- {%- else -%}
|
|
- {{ serialize_pep440(bump_version(base), stage, revision, dev=distance, metadata=[commit]) }}
|
|
- {%- endif -%}
|
|
-"""
|
|
-
|
|
-[tool.poetry-dynamic-versioning.files."qats/_version.py"]
|
|
-persistent-substitution = true
|
|
-initial-content = """
|
|
-# file generated by poetry dynamic versioning during poetry build/install
|
|
-# don't change, don't track in version control
|
|
-__version__ = "0.0.0"
|
|
-__version_tuple__ = (0, 0, 0)
|
|
-"""
|
|
[build-system]
|
|
# https://pypi.org/project/poetry-dynamic-versioning/
|
|
requires = ["poetry-core>=1.0.0", "poetry-dynamic-versioning>=1.1.1,<2.0.0"]
|