mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 15:36:35 -04:00
SlimIt is a JavaScript minifier written in Python. It compiles JavaScript into more compact code so that it downloads and runs faster. SlimIt also provides a library that includes a JavaScript parser, lexer, pretty printer and a tree visitor. WWW: http://slimit.readthedocs.org PR: 191386 (with minor changes) Submitted by: Melvyn Sopacua <melvyn at magemana dot nl>
11 lines
364 B
Python
11 lines
364 B
Python
--- setup.py.orig 2013-03-26 09:09:32.000000000 +0100
|
|
+++ setup.py 2014-08-01 21:18:22.838964037 +0200
|
|
@@ -52,6 +52,7 @@
|
|
""",
|
|
classifiers=filter(None, classifiers.split('\n')),
|
|
long_description=read('README.rst') + '\n\n' + read('CHANGES'),
|
|
- extras_require={'test': []}
|
|
+ extras_require={'test': []},
|
|
+ test_suite='slimit.tests',
|
|
)
|
|
|