ports/www/qt5-webengine/files/patch-src_3rdparty_chromium_base_cpu.cc
Kai Knoblich 8067206f03 www/qt5-webengine: Update to 5.15.8
* Under the hood runs Chromium 87.0.4280.144 with security fixes up to
  version 96.0.4664.110 and patches were taken from of www/chromium
  87.0.4280.141 (391acded85).

* Prune some unneeded patches (mostly from the headless and unittest
  areas) and try to align the unbundling of dependencies similar to
  qt6-webengine for consistency.

* Adjust Mk/Uses/qt-dist.mk accordingly as the naming of the distfiles
  has changed since Qt 5.15.3.

Tested by:	tcberner
Differential Revision:	https://reviews.freebsd.org/D38165
2023-03-06 05:33:32 +01:00

44 lines
1.4 KiB
C++

--- src/3rdparty/chromium/base/cpu.cc.orig 2021-12-15 16:12:54 UTC
+++ src/3rdparty/chromium/base/cpu.cc
@@ -16,7 +16,7 @@
#include "base/stl_util.h"
-#if defined(OS_LINUX) || defined(OS_CHROMEOS) || defined(OS_ANDROID) || \
+#if defined(OS_LINUX) || defined(OS_CHROMEOS) || defined(OS_ANDROID) || defined(OS_BSD) || \
defined(OS_AIX)
#include "base/containers/flat_set.h"
#include "base/files/file_util.h"
@@ -31,7 +31,7 @@
#endif
#if defined(ARCH_CPU_ARM_FAMILY) && \
- (defined(OS_ANDROID) || defined(OS_LINUX) || defined(OS_CHROMEOS))
+ (defined(OS_ANDROID) || defined(OS_LINUX) || defined(OS_CHROMEOS))
#include "base/files/file_util.h"
#endif
@@ -182,6 +182,14 @@ std::string* CpuInfoBrand() {
return brand;
}
+#elif defined(OS_BSD)
+std::string* CpuInfoBrand() {
+ static std::string* brand = []() {
+ return new std::string(SysInfo::CPUModelName());
+ }();
+
+ return brand;
+}
#endif // defined(ARCH_CPU_ARM_FAMILY) && (defined(OS_ANDROID) ||
// defined(OS_LINUX) || defined(OS_CHROMEOS))
@@ -305,7 +313,7 @@ void CPU::Initialize() {
}
}
#elif defined(ARCH_CPU_ARM_FAMILY)
-#if defined(OS_ANDROID) || defined(OS_LINUX) || defined(OS_CHROMEOS)
+#if defined(OS_ANDROID) || defined(OS_LINUX) || defined(OS_CHROMEOS) || defined(OS_BSD)
cpu_brand_ = *CpuInfoBrand();
#elif defined(OS_WIN)
// Windows makes high-resolution thread timing information available in