mirror of
https://git.freebsd.org/ports.git
synced 2025-05-03 03:56:39 -04:00
Reviewed by: pizzamig (maintainer) Differential Revision: https://reviews.freebsd.org/D38759
525 lines
14 KiB
Text
525 lines
14 KiB
Text
diff --git gdb/Makefile.in gdb/Makefile.in
|
|
index 321a58c4635..57a45c391ef 100644
|
|
--- gdb/Makefile.in
|
|
+++ gdb/Makefile.in
|
|
@@ -696,6 +696,7 @@ TARGET_OBS = @TARGET_OBS@
|
|
# All target-dependent objects files that require 64-bit CORE_ADDR
|
|
# (used with --enable-targets=all --enable-64-bit-bfd).
|
|
ALL_64_TARGET_OBS = \
|
|
+ aarch64-fbsd-kern.o \
|
|
aarch64-fbsd-tdep.o \
|
|
aarch64-linux-tdep.o \
|
|
aarch64-newlib-tdep.o \
|
|
@@ -710,6 +711,7 @@ ALL_64_TARGET_OBS = \
|
|
amd64-darwin-tdep.o \
|
|
amd64-dicos-tdep.o \
|
|
amd64-fbsd-tdep.o \
|
|
+ amd64fbsd-kern.o \
|
|
amd64-linux-tdep.o \
|
|
amd64-netbsd-tdep.o \
|
|
amd64-obsd-tdep.o \
|
|
@@ -728,18 +730,21 @@ ALL_64_TARGET_OBS = \
|
|
ia64-vms-tdep.o \
|
|
loongarch-linux-tdep.o \
|
|
loongarch-tdep.o \
|
|
+ mipsfbsd-kern.o \
|
|
mips-fbsd-tdep.o \
|
|
mips-linux-tdep.o \
|
|
mips-netbsd-tdep.o \
|
|
mips-sde-tdep.o \
|
|
mips-tdep.o \
|
|
mips64-obsd-tdep.o \
|
|
+ riscv-fbsd-kern.o \
|
|
riscv-fbsd-tdep.o \
|
|
riscv-linux-tdep.o \
|
|
riscv-none-tdep.o \
|
|
riscv-ravenscar-thread.o \
|
|
riscv-tdep.o \
|
|
sparc64-fbsd-tdep.o \
|
|
+ sparc64fbsd-kern.o \
|
|
sparc64-linux-tdep.o \
|
|
sparc64-netbsd-tdep.o \
|
|
sparc64-obsd-tdep.o \
|
|
@@ -764,6 +769,7 @@ ALL_TARGET_OBS = \
|
|
arch/loongarch.o \
|
|
arch/ppc-linux-common.o \
|
|
arm-bsd-tdep.o \
|
|
+ arm-fbsd-kern.o \
|
|
arm-fbsd-tdep.o \
|
|
arm-linux-tdep.o \
|
|
arm-netbsd-tdep.o \
|
|
@@ -781,6 +787,8 @@ ALL_TARGET_OBS = \
|
|
csky-linux-tdep.o \
|
|
csky-tdep.o \
|
|
dicos-tdep.o \
|
|
+ fbsd-kld.o \
|
|
+ fbsd-kthr.o \
|
|
fbsd-tdep.o \
|
|
frv-linux-tdep.o \
|
|
frv-tdep.o \
|
|
@@ -795,6 +803,7 @@ ALL_TARGET_OBS = \
|
|
i386-bsd-tdep.o \
|
|
i386-darwin-tdep.o \
|
|
i386-dicos-tdep.o \
|
|
+ i386fbsd-kern.o \
|
|
i386-fbsd-tdep.o \
|
|
i386-gnu-tdep.o \
|
|
i386-go32-tdep.o \
|
|
@@ -832,6 +841,7 @@ ALL_TARGET_OBS = \
|
|
obsd-tdep.o \
|
|
or1k-linux-tdep.o \
|
|
or1k-tdep.o \
|
|
+ ppcfbsd-kern.o \
|
|
ppc-fbsd-tdep.o \
|
|
ppc-linux-tdep.o \
|
|
ppc-netbsd-tdep.o \
|
|
@@ -1622,6 +1632,7 @@ ALLDEPFILES = \
|
|
arch/riscv.c \
|
|
arch/tic6x.c \
|
|
aarch32-tdep.c \
|
|
+ aarch64-fbsd-kern.c \
|
|
aarch64-fbsd-nat.c \
|
|
aarch64-fbsd-tdep.c \
|
|
aarch64-linux-nat.c \
|
|
@@ -1641,6 +1652,7 @@ ALLDEPFILES = \
|
|
amd64-bsd-nat.c \
|
|
amd64-darwin-tdep.c \
|
|
amd64-dicos-tdep.c \
|
|
+ amd64fbsd-kern.c \
|
|
amd64-fbsd-nat.c \
|
|
amd64-fbsd-tdep.c \
|
|
amd64-linux-nat.c \
|
|
@@ -1656,6 +1668,7 @@ ALLDEPFILES = \
|
|
arc-linux-nat.c \
|
|
arc-tdep.c \
|
|
arm-bsd-tdep.c \
|
|
+ arm-fbsd-kern.c \
|
|
arm-fbsd-nat.c \
|
|
arm-fbsd-tdep.c \
|
|
arm-linux-nat.c \
|
|
@@ -1675,6 +1688,9 @@ ALLDEPFILES = \
|
|
csky-tdep.c \
|
|
darwin-nat.c \
|
|
dicos-tdep.c \
|
|
+ fbsd-kld.c \
|
|
+ fbsd-kthr.c \
|
|
+ fbsd-kvm.c \
|
|
fbsd-nat.c \
|
|
fbsd-tdep.c \
|
|
fork-child.c \
|
|
@@ -1695,6 +1711,7 @@ ALLDEPFILES = \
|
|
i386-darwin-nat.c \
|
|
i386-darwin-tdep.c \
|
|
i386-dicos-tdep.c \
|
|
+ i386fbsd-kern.c \
|
|
i386-fbsd-nat.c \
|
|
i386-fbsd-tdep.c \
|
|
i386-gnu-nat.c \
|
|
@@ -1735,6 +1752,7 @@ ALLDEPFILES = \
|
|
microblaze-linux-tdep.c \
|
|
microblaze-tdep.c \
|
|
mingw-hdep.c \
|
|
+ mipsfbsd-kern.c \
|
|
mips-fbsd-nat.c \
|
|
mips-fbsd-tdep.c \
|
|
mips-linux-nat.c \
|
|
@@ -1755,6 +1773,7 @@ ALLDEPFILES = \
|
|
obsd-tdep.c \
|
|
or1k-linux-nat.c \
|
|
posix-hdep.c \
|
|
+ ppcfbsd-kern.c \
|
|
ppc-fbsd-nat.c \
|
|
ppc-fbsd-tdep.c \
|
|
ppc-linux-nat.c \
|
|
@@ -1769,6 +1788,7 @@ ALLDEPFILES = \
|
|
procfs.c \
|
|
ravenscar-thread.c \
|
|
remote-sim.c \
|
|
+ riscv-fbsd-kern.c \
|
|
riscv-fbsd-nat.c \
|
|
riscv-fbsd-tdep.c \
|
|
riscv-linux-nat.c \
|
|
@@ -1805,6 +1825,7 @@ ALLDEPFILES = \
|
|
sparc-sol2-nat.c \
|
|
sparc-sol2-tdep.c \
|
|
sparc-tdep.c \
|
|
+ sparc64fbsd-kern.c \
|
|
sparc64-fbsd-nat.c \
|
|
sparc64-fbsd-tdep.c \
|
|
sparc64-linux-nat.c \
|
|
@@ -1891,7 +1912,7 @@ generated_files = \
|
|
# Flags needed to compile Python code
|
|
PYTHON_CFLAGS = @PYTHON_CFLAGS@
|
|
|
|
-all: gdb$(EXEEXT) $(CONFIG_ALL) gdb-gdb.py gdb-gdb.gdb
|
|
+all: gdb$(EXEEXT) kgdb$(EXEEXT) $(CONFIG_ALL) gdb-gdb.py gdb-gdb.gdb
|
|
@$(MAKE) $(FLAGS_TO_PASS) DO=all "DODIRS=$(SUBDIRS)" subdir_do
|
|
|
|
# Rule for compiling .c files in the top-level gdb directory.
|
|
@@ -2154,6 +2175,12 @@ ifneq ($(CODESIGN_CERT),)
|
|
$(ECHO_SIGN) $(CODESIGN) -s $(CODESIGN_CERT) gdb$(EXEEXT)
|
|
endif
|
|
|
|
+kgdb$(EXEEXT): kgdb-main.o $(LIBGDB_OBS) $(ADD_DEPS) $(CDEPS) $(TDEPLIBS)
|
|
+ $(SILENCE) rm -f kgdb$(EXEEXT)
|
|
+ $(ECHO_CXXLD) $(CC_LD) $(INTERNAL_LDFLAGS) $(WIN32LDAPP) \
|
|
+ -o kgdb$(EXEEXT) kgdb-main.o $(LIBGDB_OBS) \
|
|
+ $(TDEPLIBS) $(TUI_LIBRARY) $(CLIBS) $(LOADLIBES)
|
|
+
|
|
# This is useful when debugging GDB, because some Unix's don't let you run GDB
|
|
# on itself without copying the executable. So "make gdb1" will make
|
|
# gdb and put a copy in gdb1, and you can run it with "gdb gdb1".
|
|
@@ -2189,6 +2216,7 @@ clean mostlyclean: $(CONFIG_CLEAN)
|
|
rm -f init.c stamp-init version.c stamp-version
|
|
rm -f gdb$(EXEEXT) core make.log
|
|
rm -f gdb[0-9]$(EXEEXT)
|
|
+ rm -f kgdb$(EXEEXT)
|
|
rm -f test-cp-name-parser$(EXEEXT)
|
|
rm -f xml-builtin.c stamp-xml
|
|
rm -f $(DEPDIR)/*
|
|
@@ -2608,7 +2636,7 @@ endif
|
|
|
|
# A list of all the objects we might care about in this build, for
|
|
# dependency tracking.
|
|
-all_object_files = gdb.o $(LIBGDB_OBS) gdbtk-main.o \
|
|
+all_object_files = kgdb-main.o gdb.o $(LIBGDB_OBS) gdbtk-main.o \
|
|
test-cp-name-parser.o
|
|
|
|
# All the .deps files to include.
|
|
diff --git gdb/config.in gdb/config.in
|
|
index 736e6be1c48..7df4d954db0 100644
|
|
--- gdb/config.in
|
|
+++ gdb/config.in
|
|
@@ -223,6 +223,12 @@
|
|
/* Define to 1 if you have the `kinfo_getfile' function. */
|
|
#undef HAVE_KINFO_GETFILE
|
|
|
|
+/* Define to 1 if your system has the kvm_kerndisp function. */
|
|
+#undef HAVE_KVM_DISP
|
|
+
|
|
+/* Define to 1 if your system has the kvm_open2 function. */
|
|
+#undef HAVE_KVM_OPEN2
|
|
+
|
|
/* Define if you have <langinfo.h> and nl_langinfo(CODESET). */
|
|
#undef HAVE_LANGINFO_CODESET
|
|
|
|
diff --git gdb/configure gdb/configure
|
|
index bdc84be9c01..607ee3618cc 100755
|
|
--- gdb/configure
|
|
+++ gdb/configure
|
|
@@ -19476,6 +19476,126 @@ fi
|
|
|
|
|
|
|
|
+# kgdb needs kvm_open2 for cross-debugging
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing kvm_open2" >&5
|
|
+$as_echo_n "checking for library containing kvm_open2... " >&6; }
|
|
+if ${ac_cv_search_kvm_open2+:} false; then :
|
|
+ $as_echo_n "(cached) " >&6
|
|
+else
|
|
+ ac_func_search_save_LIBS=$LIBS
|
|
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
+/* end confdefs.h. */
|
|
+
|
|
+/* Override any GCC internal prototype to avoid an error.
|
|
+ Use char because int might match the return type of a GCC
|
|
+ builtin and then its argument prototype would still apply. */
|
|
+#ifdef __cplusplus
|
|
+extern "C"
|
|
+#endif
|
|
+char kvm_open2 ();
|
|
+int
|
|
+main ()
|
|
+{
|
|
+return kvm_open2 ();
|
|
+ ;
|
|
+ return 0;
|
|
+}
|
|
+_ACEOF
|
|
+for ac_lib in '' kvm; do
|
|
+ if test -z "$ac_lib"; then
|
|
+ ac_res="none required"
|
|
+ else
|
|
+ ac_res=-l$ac_lib
|
|
+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
|
|
+ fi
|
|
+ if ac_fn_c_try_link "$LINENO"; then :
|
|
+ ac_cv_search_kvm_open2=$ac_res
|
|
+fi
|
|
+rm -f core conftest.err conftest.$ac_objext \
|
|
+ conftest$ac_exeext
|
|
+ if ${ac_cv_search_kvm_open2+:} false; then :
|
|
+ break
|
|
+fi
|
|
+done
|
|
+if ${ac_cv_search_kvm_open2+:} false; then :
|
|
+
|
|
+else
|
|
+ ac_cv_search_kvm_open2=no
|
|
+fi
|
|
+rm conftest.$ac_ext
|
|
+LIBS=$ac_func_search_save_LIBS
|
|
+fi
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_kvm_open2" >&5
|
|
+$as_echo "$ac_cv_search_kvm_open2" >&6; }
|
|
+ac_res=$ac_cv_search_kvm_open2
|
|
+if test "$ac_res" != no; then :
|
|
+ test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
|
|
+
|
|
+$as_echo "#define HAVE_KVM_OPEN2 1" >>confdefs.h
|
|
+
|
|
+fi
|
|
+
|
|
+
|
|
+# kgdb needs kvm_kerndisp for relocatable kernels
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing kvm_kerndisp" >&5
|
|
+$as_echo_n "checking for library containing kvm_kerndisp... " >&6; }
|
|
+if ${ac_cv_search_kvm_kerndisp+:} false; then :
|
|
+ $as_echo_n "(cached) " >&6
|
|
+else
|
|
+ ac_func_search_save_LIBS=$LIBS
|
|
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
+/* end confdefs.h. */
|
|
+
|
|
+/* Override any GCC internal prototype to avoid an error.
|
|
+ Use char because int might match the return type of a GCC
|
|
+ builtin and then its argument prototype would still apply. */
|
|
+#ifdef __cplusplus
|
|
+extern "C"
|
|
+#endif
|
|
+char kvm_kerndisp ();
|
|
+int
|
|
+main ()
|
|
+{
|
|
+return kvm_kerndisp ();
|
|
+ ;
|
|
+ return 0;
|
|
+}
|
|
+_ACEOF
|
|
+for ac_lib in '' kvm; do
|
|
+ if test -z "$ac_lib"; then
|
|
+ ac_res="none required"
|
|
+ else
|
|
+ ac_res=-l$ac_lib
|
|
+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
|
|
+ fi
|
|
+ if ac_fn_c_try_link "$LINENO"; then :
|
|
+ ac_cv_search_kvm_kerndisp=$ac_res
|
|
+fi
|
|
+rm -f core conftest.err conftest.$ac_objext \
|
|
+ conftest$ac_exeext
|
|
+ if ${ac_cv_search_kvm_kerndisp+:} false; then :
|
|
+ break
|
|
+fi
|
|
+done
|
|
+if ${ac_cv_search_kvm_kerndisp+:} false; then :
|
|
+
|
|
+else
|
|
+ ac_cv_search_kvm_kerndisp=no
|
|
+fi
|
|
+rm conftest.$ac_ext
|
|
+LIBS=$ac_func_search_save_LIBS
|
|
+fi
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_kvm_kerndisp" >&5
|
|
+$as_echo "$ac_cv_search_kvm_kerndisp" >&6; }
|
|
+ac_res=$ac_cv_search_kvm_kerndisp
|
|
+if test "$ac_res" != no; then :
|
|
+ test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
|
|
+
|
|
+$as_echo "#define HAVE_KVM_DISP 1" >>confdefs.h
|
|
+
|
|
+fi
|
|
+
|
|
+
|
|
|
|
# Check whether --with-zstd was given.
|
|
if test "${with_zstd+set}" = set; then :
|
|
diff --git gdb/configure.ac gdb/configure.ac
|
|
index c81df8c4967..b3e1b3b5283 100644
|
|
--- gdb/configure.ac
|
|
+++ gdb/configure.ac
|
|
@@ -472,6 +472,16 @@ AC_SEARCH_LIBS(socketpair, socket)
|
|
AM_ZLIB
|
|
AC_ZSTD
|
|
|
|
+# kgdb needs kvm_open2 for cross-debugging
|
|
+AC_SEARCH_LIBS(kvm_open2, kvm,
|
|
+ [AC_DEFINE(HAVE_KVM_OPEN2, 1,
|
|
+ [Define to 1 if your system has the kvm_open2 function. ])])
|
|
+
|
|
+# kgdb needs kvm_kerndisp for relocatable kernels
|
|
+AC_SEARCH_LIBS(kvm_kerndisp, kvm,
|
|
+ [AC_DEFINE(HAVE_KVM_DISP, 1,
|
|
+ [Define to 1 if your system has the kvm_kerndisp function. ])])
|
|
+
|
|
AM_ICONV
|
|
|
|
# GDB may fork/exec the iconv program to get the list of supported character
|
|
diff --git gdb/configure.nat gdb/configure.nat
|
|
index aabcdeff989..6aeee4b61fa 100644
|
|
--- gdb/configure.nat
|
|
+++ gdb/configure.nat
|
|
@@ -63,7 +63,8 @@ case ${gdb_host} in
|
|
LOADLIBES='-ldl $(RDYNAMIC)'
|
|
;;
|
|
fbsd*)
|
|
- NATDEPFILES='fork-child.o nat/fork-inferior.o inf-ptrace.o fbsd-nat.o'
|
|
+ NATDEPFILES='fork-child.o nat/fork-inferior.o inf-ptrace.o fbsd-nat.o \
|
|
+ fbsd-kvm.o'
|
|
HAVE_NATIVE_GCORE_HOST=1
|
|
LOADLIBES='-lkvm'
|
|
;;
|
|
diff --git gdb/configure.tgt gdb/configure.tgt
|
|
index e84e222ba0d..cd3ef37fac6 100644
|
|
--- gdb/configure.tgt
|
|
+++ gdb/configure.tgt
|
|
@@ -115,7 +115,7 @@ esac
|
|
|
|
case "${targ}" in
|
|
*-*-freebsd* | *-*-kfreebsd*-gnu)
|
|
- os_obs="fbsd-tdep.o solib-svr4.o";;
|
|
+ os_obs="fbsd-tdep.o solib-svr4.o fbsd-kld.o fbsd-kthr.o";;
|
|
*-*-netbsd* | *-*-knetbsd*-gnu)
|
|
os_obs="netbsd-tdep.o solib-svr4.o";;
|
|
*-*-openbsd*)
|
|
@@ -132,7 +132,7 @@ aarch64*-*-elf | aarch64*-*-rtems*)
|
|
|
|
aarch64*-*-freebsd*)
|
|
# Target: FreeBSD/aarch64
|
|
- gdb_target_obs="aarch64-fbsd-tdep.o"
|
|
+ gdb_target_obs="aarch64-fbsd-tdep.o aarch64-fbsd-kern.o"
|
|
;;
|
|
|
|
aarch64*-*-linux*)
|
|
@@ -188,7 +188,7 @@ arm*-*-linux*)
|
|
;;
|
|
arm*-*-freebsd*)
|
|
# Target: FreeBSD/arm
|
|
- gdb_target_obs="arm-fbsd-tdep.o"
|
|
+ gdb_target_obs="arm-fbsd-tdep.o arm-fbsd-kern.o"
|
|
;;
|
|
arm*-*-netbsd* | arm*-*-knetbsd*-gnu)
|
|
# Target: NetBSD/arm
|
|
@@ -280,7 +280,11 @@ i[34567]86-*-dicos*)
|
|
;;
|
|
i[34567]86-*-freebsd* | i[34567]86-*-kfreebsd*-gnu)
|
|
# Target: FreeBSD/i386
|
|
- gdb_target_obs="i386-bsd-tdep.o i386-fbsd-tdep.o "
|
|
+ gdb_target_obs="i386-bsd-tdep.o i386-fbsd-tdep.o i386fbsd-kern.o"
|
|
+ if test "x$enable_64_bit_bfd" = "xyes"; then
|
|
+ # Target: FreeBSD amd64
|
|
+ gdb_target_obs="amd64fbsd-tdep.o amd64fbsd-kern.o ${gdb_target_obs}"
|
|
+ fi
|
|
;;
|
|
i[34567]86-*-netbsd* | i[34567]86-*-knetbsd*-gnu)
|
|
# Target: NetBSD/i386
|
|
@@ -420,7 +424,7 @@ mips*-*-netbsd* | mips*-*-knetbsd*-gnu)
|
|
;;
|
|
mips*-*-freebsd*)
|
|
# Target: MIPS running FreeBSD
|
|
- gdb_target_obs="mips-tdep.o mips-fbsd-tdep.o"
|
|
+ gdb_target_obs="mips-tdep.o mips-fbsd-tdep.o mipsfbsd-kern.o"
|
|
;;
|
|
mips64*-*-openbsd*)
|
|
# Target: OpenBSD/mips64
|
|
@@ -478,7 +482,7 @@ or1k-*-* | or1knd-*-*)
|
|
powerpc*-*-freebsd*)
|
|
# Target: FreeBSD/powerpc
|
|
gdb_target_obs="rs6000-tdep.o ppc-sysv-tdep.o ppc64-tdep.o \
|
|
- ppc-fbsd-tdep.o \
|
|
+ ppc-fbsd-tdep.o ppcfbsd-kern.o \
|
|
ravenscar-thread.o ppc-ravenscar-thread.o"
|
|
;;
|
|
|
|
@@ -527,7 +531,7 @@ s390*-*-linux*)
|
|
|
|
riscv*-*-freebsd*)
|
|
# Target: FreeBSD/riscv
|
|
- gdb_target_obs="riscv-fbsd-tdep.o"
|
|
+ gdb_target_obs="riscv-fbsd-tdep.o riscv-fbsd-kern.o"
|
|
;;
|
|
|
|
riscv*-*-linux*)
|
|
@@ -592,6 +596,7 @@ sparc64-*-linux*)
|
|
sparc*-*-freebsd* | sparc*-*-kfreebsd*-gnu)
|
|
# Target: FreeBSD/sparc64
|
|
gdb_target_obs="sparc-tdep.o sparc64-tdep.o sparc64-fbsd-tdep.o \
|
|
+ sparc64fbsd-kern.o \
|
|
ravenscar-thread.o sparc-ravenscar-thread.o"
|
|
;;
|
|
sparc-*-netbsd* | sparc-*-knetbsd*-gnu)
|
|
@@ -708,8 +713,8 @@ x86_64-*-linux*)
|
|
;;
|
|
x86_64-*-freebsd* | x86_64-*-kfreebsd*-gnu)
|
|
# Target: FreeBSD/amd64
|
|
- gdb_target_obs="amd64-fbsd-tdep.o ${i386_tobjs} \
|
|
- i386-bsd-tdep.o i386-fbsd-tdep.o"
|
|
+ gdb_target_obs="amd64-fbsd-tdep.o amd64fbsd-kern.o ${i386_tobjs} \
|
|
+ i386-bsd-tdep.o i386-fbsd-tdep.o i386fbsd-kern.o"
|
|
;;
|
|
x86_64-*-mingw* | x86_64-*-cygwin*)
|
|
# Target: MingW/amd64
|
|
diff --git gdb/osabi.c gdb/osabi.c
|
|
index d18802ac3a4..4f3aa6a52da 100644
|
|
--- gdb/osabi.c
|
|
+++ gdb/osabi.c
|
|
@@ -67,6 +67,7 @@ static const struct osabi_names gdb_osabi_names[] =
|
|
{ "Solaris", NULL },
|
|
{ "GNU/Linux", "linux(-gnu[^-]*)?" },
|
|
{ "FreeBSD", NULL },
|
|
+ { "FreeBSD/kernel", NULL },
|
|
{ "NetBSD", NULL },
|
|
{ "OpenBSD", NULL },
|
|
{ "WindowsCE", NULL },
|
|
diff --git gdb/osabi.h gdb/osabi.h
|
|
index 35f14ec433c..1276d34d5f7 100644
|
|
--- gdb/osabi.h
|
|
+++ gdb/osabi.h
|
|
@@ -31,6 +31,7 @@ enum gdb_osabi
|
|
GDB_OSABI_SOLARIS,
|
|
GDB_OSABI_LINUX,
|
|
GDB_OSABI_FREEBSD,
|
|
+ GDB_OSABI_FREEBSD_KERNEL,
|
|
GDB_OSABI_NETBSD,
|
|
GDB_OSABI_OPENBSD,
|
|
GDB_OSABI_WINCE,
|
|
diff --git gdb/regcache.c gdb/regcache.c
|
|
index 56b6d047874..47637c628a7 100644
|
|
--- gdb/regcache.c
|
|
+++ gdb/regcache.c
|
|
@@ -1112,6 +1112,22 @@ reg_buffer::raw_supply_zeroed (int regnum)
|
|
m_register_status[regnum] = REG_VALID;
|
|
}
|
|
|
|
+void
|
|
+reg_buffer::raw_supply_unsigned (int regnum, ULONGEST val)
|
|
+{
|
|
+ enum bfd_endian byte_order = gdbarch_byte_order (m_descr->gdbarch);
|
|
+ gdb_byte *regbuf;
|
|
+ size_t regsize;
|
|
+
|
|
+ assert_regnum (regnum);
|
|
+
|
|
+ regbuf = register_buffer (regnum);
|
|
+ regsize = m_descr->sizeof_register[regnum];
|
|
+
|
|
+ store_unsigned_integer (regbuf, regsize, byte_order, val);
|
|
+ m_register_status[regnum] = REG_VALID;
|
|
+}
|
|
+
|
|
/* See gdbsupport/common-regcache.h. */
|
|
|
|
void
|
|
diff --git gdb/regcache.h gdb/regcache.h
|
|
index b9ffab9950d..f32d7a3bd00 100644
|
|
--- gdb/regcache.h
|
|
+++ gdb/regcache.h
|
|
@@ -237,6 +237,8 @@ class reg_buffer : public reg_buffer_common
|
|
only LEN, without editing the rest of the register. */
|
|
void raw_supply_part (int regnum, int offset, int len, const gdb_byte *in);
|
|
|
|
+ void raw_supply_unsigned (int regnum, ULONGEST val);
|
|
+
|
|
void invalidate (int regnum);
|
|
|
|
virtual ~reg_buffer () = default;
|