ports/security/sssd/files/patch-src__external__pac_responder.m4
Mateusz Piotrowski ae334add4b security/sssd: Fix pkg-plist and chase krb5 update
This patch fixes two issues.

The first issue was presence of missing files of the SSSDConfig Python
module: PKG-INFO, SOURCES.txt, dependency_links., and top_level.txt. It
looks like those files are not installed anymore so let's just remove
them from pkg-plist.

The other issue was the build system not accepting the new version of
secruity/krb5. The fix is to patch sssd's build system to accept the new
version. This is how we fixed previous incarnations of this bug in the
past.

PR:		271939
Reported by:	ddrinnon@cdor.net
Fixes:	7228a09df0 security/krb5: krb5-121 is now default
MFH:		2023Q3
Sponsored by:	Klara Inc.
2023-07-13 11:43:49 +02:00

24 lines
919 B
Text

--- src/external/pac_responder.m4.orig 2020-03-17 13:31:28 UTC
+++ src/external/pac_responder.m4
@@ -7,7 +7,7 @@ AC_ARG_ENABLE([pac-responder],
krb5_version_ok=no
if test x$build_pac_responder = xyes
then
- AC_PATH_PROG(KRB5_CONFIG, krb5-config)
+ AC_PATH_TOOL(KRB5_CONFIG, krb5-config, [], [/usr/local/bin:$PATH])
AC_MSG_CHECKING(for supported MIT krb5 version)
KRB5_VERSION="`$KRB5_CONFIG --version`"
case $KRB5_VERSION in
@@ -19,7 +19,11 @@ then
Kerberos\ 5\ release\ 1.14* | \
Kerberos\ 5\ release\ 1.15* | \
Kerberos\ 5\ release\ 1.16* | \
- Kerberos\ 5\ release\ 1.17*)
+ Kerberos\ 5\ release\ 1.17* | \
+ Kerberos\ 5\ release\ 1.18* | \
+ Kerberos\ 5\ release\ 1.19* | \
+ Kerberos\ 5\ release\ 1.20* | \
+ Kerberos\ 5\ release\ 1.21*)
krb5_version_ok=yes
AC_MSG_RESULT([yes])
;;