mirror of
https://git.freebsd.org/ports.git
synced 2025-05-13 15:51:51 -04:00
This patch introduces security/py-angr/Makefile.version file, which stores the shared version of all the angr ports (as ANGR_VERSION). It also stores the tagname of a distribution file, which is required for testing (ANGR_BINARIES_TAGNAME).
28 lines
772 B
Text
28 lines
772 B
Text
--- pyvex_c/Makefile.orig 2020-09-17 20:10:23 UTC
|
|
+++ pyvex_c/Makefile
|
|
@@ -4,6 +4,11 @@ ifeq ($(UNAME), Darwin)
|
|
STATIC_LIBRARY_FILE=libpyvex.a
|
|
LDFLAGS=-Wl,-install_name,@rpath/$(LIBRARY_FILE)
|
|
endif
|
|
+ifeq ($(UNAME), FreeBSD)
|
|
+ LIBRARY_FILE=libpyvex.so
|
|
+ STATIC_LIBRARY_FILE=libpyvex.a
|
|
+ LDFLAGS=-Wl,-soname,$(LIBRARY_FILE) %%LDFLAGS%%
|
|
+endif
|
|
ifeq ($(UNAME), Linux)
|
|
LIBRARY_FILE=libpyvex.so
|
|
STATIC_LIBRARY_FILE=libpyvex.a
|
|
@@ -26,10 +31,10 @@ sp =$(null) $(null)
|
|
qs = $(subst ?,$(sp),$1)
|
|
sq = $(subst $(sp),?,$1)
|
|
|
|
-CC=gcc
|
|
-AR=ar
|
|
+CC?=gcc
|
|
+AR?=ar
|
|
INCFLAGS=-I "$(VEX_INCLUDE_PATH)"
|
|
-CFLAGS=-g -O2 -Wall -shared -fPIC -std=c99 $(INCFLAGS)
|
|
+CFLAGS=-g %%CFLAGS%% -Wall -shared -fPIC $(INCFLAGS)
|
|
|
|
OBJECTS=pyvex.o logging.o analysis.o postprocess.o
|
|
HEADERS=pyvex.h
|