ports/security/pev/files/patch-src_Makefile
Yasuhiro Kimura 5df45234fa security/pev: Move man pages to share/man
Approved by:	portmgr (blanket)
2024-03-29 17:15:34 +09:00

29 lines
1 KiB
Text

--- src/Makefile.orig 2017-01-07 22:34:07 UTC
+++ src/Makefile
@@ -52,7 +52,7 @@ endif
####### Compiler options
-override LDFLAGS += -L$(LIBPE) -lpe -ldl
+override LDFLAGS += -L$(LIBPE) -lpe
override CFLAGS += -I$(LIBPE) -I"../include" -W -Wall -Wextra -std=c99 -pedantic
override CPPFLAGS += -D_GNU_SOURCE -DSHAREDIR="\"$(SHAREDIR)"\"
@@ -145,6 +145,17 @@ install: installdirs
install: installdirs
for prog in $(PROGS); do \
$(INSTALL_PROGRAM) $(pev_BUILDDIR)/$$prog $(DESTDIR)$(bindir); \
+ $(CHK_FILE_EXISTS) $(MANDIR)/$$prog$(man1ext) && \
+ gzip -c -9 $(MANDIR)/$$prog$(man1ext) > $(DESTDIR)$(man1dir)/$$prog$(man1ext).gz || \
+ echo -n; \
+ done
+
+ $(INSTALL_DATA) $(srcdir)/userdb.txt $(DESTDIR)$(SHAREDIR)
+ cd $(PLUGINS_DIR) && $(MAKE) $@
+
+install-strip: installdirs
+ for prog in $(PROGS); do \
+ $(INSTALL_PROGRAM) -s $(pev_BUILDDIR)/$$prog $(DESTDIR)$(bindir); \
$(CHK_FILE_EXISTS) $(MANDIR)/$$prog$(man1ext) && \
gzip -c -9 $(MANDIR)/$$prog$(man1ext) > $(DESTDIR)$(man1dir)/$$prog$(man1ext).gz || \
echo -n; \