ports/security/opensc/files/patch-etc_Makefile.am
Tobias Kortkamp 161db1264b security/opensc: Fix sample config install
Error: Missing: %%ETCDIR%%.conf.sample
[...]
Installing opensc-0.19.0...
cp: /usr/local/etc/opensc.conf.sample: No such file or directory

The build uses USES=autoreconf and patching etc/Makefile.in is a
nop.  Patch etc/Makefile.am instead.

Broken in r500489.
2019-10-22 11:21:42 +00:00

17 lines
778 B
Text

--- etc/Makefile.am.orig 2018-09-13 11:52:42 UTC
+++ etc/Makefile.am
@@ -32,13 +32,7 @@ opensc.conf.example: opensc.conf.example.in force
install-exec-hook: opensc.conf.example
$(MKDIR_P) "$(DESTDIR)$(sysconfdir)"
- if [ -f "$(DESTDIR)$(sysconfdir)/opensc.conf" ]; then \
- $(INSTALL_DATA) $(srcdir)/opensc.conf "$(DESTDIR)$(sysconfdir)/opensc.conf.new"; \
- else \
- $(INSTALL_DATA) $(srcdir)/opensc.conf "$(DESTDIR)$(sysconfdir)/opensc.conf"; \
- fi
- $(MKDIR_P) "$(DESTDIR)$(docdir)"
- $(INSTALL_DATA) opensc.conf.example "$(DESTDIR)$(docdir)/opensc.conf";
+ $(INSTALL_DATA) opensc.conf.example "$(DESTDIR)$(sysconfdir)/opensc.conf.sample";
uninstall-hook: opensc.conf.example
rm -f "$(DESTDIR)$(sysconfdir)/opensc.conf.new" "$(DESTDIR)$(sysconfdir)/opensc.conf"