ports/security/nmap-devel/files/patch-liblua_Makefile
Cy Schubert c89426b1f2 security/nmap-devel: New port
Introduce nmap development port. The development branch includes
prerequisite updates including the pcre2 replacement of pcre.
This port tracks the nmap/nmap github repo.
2024-03-28 13:53:59 -07:00

13 lines
394 B
Text

--- liblua/Makefile.orig 2016-07-02 17:02:27 UTC
+++ liblua/Makefile
@@ -6,8 +6,8 @@
# Your platform. See PLATS for possible values.
PLAT= none
-CC= gcc -std=gnu99
-CFLAGS= -O2 -Wall -Wextra -DLUA_COMPAT_5_3 $(SYSCFLAGS) $(MYCFLAGS)
+CC?= gcc -std=gnu99
+CFLAGS= -Wall -Wextra -DLUA_COMPAT_5_3 $(SYSCFLAGS) $(MYCFLAGS)
LDFLAGS= $(SYSLDFLAGS) $(MYLDFLAGS)
LIBS= -lm $(SYSLIBS) $(MYLIBS)