mirror of
https://git.freebsd.org/ports.git
synced 2025-05-15 08:41:51 -04:00
Highlights: - New Roslyn compiler for C# available - Improved support for nuget packages in USES=mono General: - fix pkg-plist: mono now produces '.pdb' debug files instead of '.mdb' - bump all dependant ports USES=mono: - properly handle caching of nuget packages - add support for multiple feeds for nuget packages - add support for nuget dependencies in a separate file - add support for paket packages lang/mono: - update to version 5.2.0.215 - automate certificate initialisation [2] - increase test coverage - mark as conflicting with net/czmq (conflicting on makecert) [1] - patch mono to use $PREFIX/share/mono instead of /usr/share/.mono devel/google-gdata: - use nunit.framework nuget package as the Mono shipped version is no longer suppport. - switch to using csc(1) for compiling (mcs(1) is depreciated). - use delayed signing (and then sign with sn(1)) as csc(1) does not support signing. - fix reference to system assemblies (the '.dll' suffix is required). - fix reference to HttpUtility: csc(1) is more strict about scoping devel/monodevelop: - reroll distinfo (no changes to content) lang/fsharp: - reroll distinfo (no changes to content) security/gnome-keyring-sharp: - delay sign (then sign with sn(1)) as csc(1) does not support direct signing. PR: 223188 [1] PR: 209670 [2] Differential Revision: https://reviews.freebsd.org/D13752
8 lines
456 B
C#
8 lines
456 B
C#
--- src/Gnome.Keyring/AssemblyInfo.cs.in.orig 2010-06-30 23:06:58 UTC
|
|
+++ src/Gnome.Keyring/AssemblyInfo.cs.in
|
|
@@ -35,5 +35,6 @@ using System.Runtime.CompilerServices;
|
|
[assembly: AssemblyDescription ("Client library to access the GNOME Keyring daemon")]
|
|
[assembly: AssemblyCopyright ("(c) 2006 Novell, Inc.")]
|
|
[assembly: AssemblyCompany ("Novell, Inc.")]
|
|
[assembly: AssemblyKeyFile ("Gnome.Keyring.snk")]
|
|
+[assembly: AssemblyDelaySignAttribute (true)]
|