ports/devel/aws-c-commons/files/patch-CMakeLists.txt
Danilo Egea Gondolfo f931478254 - Update to 0.3.3
2019-02-24 11:11:12 +00:00

19 lines
656 B
Text

--- CMakeLists.txt.orig 2019-02-12 00:14:23 UTC
+++ CMakeLists.txt
@@ -106,7 +106,6 @@ if (PERFORM_HEADER_CHECK)
endif()
add_library(${CMAKE_PROJECT_NAME} ${COMMON_SRC})
-aws_set_common_properties(${CMAKE_PROJECT_NAME} NO_WEXTRA)
aws_prepare_symbol_visibility_args(${CMAKE_PROJECT_NAME} "AWS_COMMON")
#apple source already includes the definitions we want, and setting this posix source
@@ -212,7 +211,7 @@ configure_file(${CONFIG_HEADER_TEMPLATE}
${GENERATED_CONFIG_HEADER}
ESCAPE_QUOTES)
-if (NOT CMAKE_CROSSCOMPILING)
+if (NOT CMAKE_CROSSCOMPILING AND BUILD_TESTING)
include(CTest)
add_subdirectory(tests)
endif()