ports/multimedia/qt6-multimedia/files/patch-src_CMakeLists.txt
Jason E. Hale 1d76bdf62d Qt6: Update to 6.6.0
Qt 6.6.0 is a feature release with focus on improving UX capabilities
including responsive UI technology and the Qt Graph module.

The Qt Coap module has been added as net/qt6-coap. [1]

PySide6 and PyQt6 have also been updated to 6.6.0.

Announcement: https://www.qt.io/blog/qt-6.6-released
Rel note: https://code.qt.io/cgit/qt/qtreleasenotes.git/about/qt/6.6.0/release-note.md

PR:		275068, 274911 [1]
MFH:		2023Q4
Exp-run by:	antoine
2023-11-23 12:43:42 -05:00

14 lines
457 B
Text

Prevent building spatialaudio_quick3d if quick3d is installed and the feature
is disabled.
--- src/CMakeLists.txt.orig 2023-11-08 02:47:23 UTC
+++ src/CMakeLists.txt
@@ -16,7 +16,7 @@ endif()
if(TARGET Qt::Quick)
add_subdirectory(multimediaquick)
endif()
-if(TARGET Qt::Quick3D AND QT_FEATURE_spatialaudio)
+if(TARGET Qt::Quick3D AND QT_FEATURE_spatialaudio AND QT_FEATURE_spatialaudio_quick3d)
add_subdirectory(spatialaudioquick3d)
endif()