ports/filesystems/ntfs2btrfs/files/patch-src_ntfs.cpp
Robert Clausecker 6e2da9672f filesystems: add new category for file systems and related utilities
The filesystems category houses file systems and file system utilities.
It is added mainly to turn the sysutils/fusefs-* pseudo-category into
a proper one, but is also useful for the sundry of other file systems
related ports found in the tree.

Ports that seem like they belong there are moved to the new category.
Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are
not moved as they currently don't fetch and don't have TIMESTAMP set
in their distinfo, but that is required to be able to push a rename
of the port by the pre-receive hook.

Approved by:	portmgr (rene)
Reviewed by:	mat
Pull Request:	https://github.com/freebsd/freebsd-ports/pull/302
PR:		281988
2024-11-06 16:17:35 +01:00

11 lines
575 B
C++

--- src/ntfs.cpp.orig 2023-05-01 20:59:36 UTC
+++ src/ntfs.cpp
@@ -465,7 +465,7 @@ string_view ntfs::find_sd(uint32_t id, ntfs_file& secu
}
static void walk_btree(const index_root& ir, const list<mapping>& mappings, const index_node_header& inh, ntfs& dev,
- const invocable<const index_entry&, string_view> auto& func, unsigned int level) {
+ const function<void(const index_entry&, string_view)>& func, unsigned int level) {
auto ent = reinterpret_cast<const index_entry*>((uint8_t*)&inh + inh.first_entry);
do {