mirror of
https://git.freebsd.org/ports.git
synced 2025-04-30 02:26:38 -04:00
- Remove reference to Linux base (Linux Compatibility not required) - Limit to architectures know to be able to enumerate serial ports on using RXTX port - Fix desktop entry - Links correct RXTX so library files depending on ARCH - Remove CHMOD usage in Makefile, and moved to pkg-plist - Fix Arduino wrapper to allow loading of sketches from the command line - Update RXTX enumeration to prevent scanning of LPT ports to increase startup speeds of Arduino IDE - Fix format of patch files - Remove bundled Linux libraries from the port prior to installation - Add support for Uarduno drivers - Fix links for java and lib files installed by port [comms/RXTX] - Update pkg-plist - Bump PORTREVISION PR: 200177 Submitted by: James Elstone, Craig Leres, swills Reported by: James Elstone Approved by: Craig Leres <leres@ee.lbl.gov> (maintainer)
13 lines
447 B
Text
13 lines
447 B
Text
--- arduino.orig 2017-03-06 20:47:44 UTC
|
|
+++ arduino
|
|
@@ -15,8 +15,9 @@ done
|
|
export CLASSPATH
|
|
|
|
LD_LIBRARY_PATH=`pwd`/lib${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
|
|
+
|
|
export LD_LIBRARY_PATH
|
|
|
|
export PATH="${APPDIR}/java/bin:${PATH}"
|
|
|
|
-java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base "$@"
|
|
+java -Dgnu.io.rxtx.CheckLPT=false -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base "$@"
|