mirror of
https://git.freebsd.org/ports.git
synced 2025-05-15 16:51:52 -04:00
to preserve version 1.x and to update to 3.0 print/py-reportlab: - Update print/py-reportlab to 3.0 based on print/py-reportlab2 - Support STAGEDIR - Use PYDISTUTILS_AUTOPLIST * Remove pkg-plist, accordingly - Set CONFLICTS - Add PORTSCOUT - Replace tab with a single space after WWW: in pkg-descr print/py-reportlab1: - Support STAGEDIR - Add PKGNAMESUFFIX not to duplicate ports with the same name - Set CONFLICTS - Use PYDISTUTILS_AUTOPLIST * Remove pkg-plist, accordingly - Make use of PORTDOCS - Set OPTIONS_DEFINE explicitly - Fix include statement - Make docs unconditional to stage - Replace tab with a single space after WWW: in pkg-descr print/py-reportlab2: - Update CONFLICTS - Set PORTSCOUT dependent ports: - Switch dependency from print/py-reportlab to print/py-reportlab1 * biology/py-biopython * deskutils/gourmet * deskutils/griffith * games/pythonsudoku * misc/pdfmap * print/py-trml2pdf * www/py-satchmo PR: ports/186970 Submitted by: tota (myself) Approved by: Muhammad Moinur Rahman (maintainer)
11 lines
422 B
Python
11 lines
422 B
Python
--- docs/genAll.py.orig 2014-02-14 23:22:37.000000000 +0900
|
|
+++ docs/genAll.py 2014-02-16 16:20:21.000000000 +0900
|
|
@@ -1,6 +1,7 @@
|
|
#!/bin/env python
|
|
-import os, sys, traceback
|
|
+import os, sys, traceback, site
|
|
def _genAll(verbose=1):
|
|
+ site.addsitedir("%%STAGEDIR%%%%PYTHON_SITELIBDIR%%")
|
|
from reportlab.lib.testutils import setOutDir
|
|
setOutDir(__name__)
|
|
from reportlab.lib.testutils import testsFolder
|