ports/www/py-django-prometheus/files/patch-setup.py
Kai Knoblich 5f45571141 www/py-django-prometheus: Convert to PEP517
* Switch to the PEP517 build framework and remove py-pytest-runner as a
  build time dependency while I'm here, because upstream of it has
  archived the project with the following notice:

  pytest-runner depends on deprecated features of setuptools and relies
  on features that break security mechanisms in pip. For example
  'setup_requires' and 'tests_require' bypass pip --require-hashes.
  See also https://github.com/pypa/setuptools/issues/1684

* Bump PORTREVISION due package change.
2024-10-06 16:27:02 +02:00

13 lines
473 B
Python

Remove py-pytest-runner as build time dependency because it is deprecated and
should be no longer used.
--- setup.py.orig 2024-10-01 12:41:04 UTC
+++ setup.py
@@ -40,7 +40,6 @@ setup(
long_description=LONG_DESCRIPTION,
long_description_content_type="text/markdown",
tests_require=["pytest", "pytest-django"],
- setup_requires=["pytest-runner"],
options={"bdist_wheel": {"universal": "1"}},
install_requires=[
"prometheus-client>=0.7",