mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 07:26:29 -04:00
remove support for them from bsd.java.mk. As Jikes is not available in Java 1.5 or higher, remove it from bsd.java.mk too (suggested by hq@) and from the ports which used it (only occurences were USE_JIKES=no). Support for the Blackdown VM is also removed, as it is not available in Java 1.5 and higher. Also remove the mapping from Java 1.1-1.4 to Java 1.5+ in bsd.java.mk to detect old, broken ports; therefore bump the minimal value of JAVA_VERSION to 1.5. While here, replace static values of JAVA_VERSION in files/*.in by %%JAVA_VERSION%% . PR: ports/158969 Submitted by: rene Tested on: pointyhat-west -exp
59 lines
1.8 KiB
INI
59 lines
1.8 KiB
INI
--- build.properties.orig 2010-02-26 12:11:41.000000000 +0100
|
|
+++ build.properties 2010-02-26 12:13:52.000000000 +0100
|
|
@@ -5,15 +5,15 @@
|
|
ant.build.javac.target=1.5
|
|
|
|
########## DEFAULT LINUX BUILD PROPERTIES ##########
|
|
-lib.swt.jni=lib/
|
|
-lib.swt.jar=lib/swt.jar
|
|
-lib.itext.jar=lib/itext.jar
|
|
-dist.file=xml/build-linux.xml
|
|
-dist.version=1.2
|
|
-dist.jar.path=./
|
|
-dist.bin.path=./
|
|
-dist.share.path=share/
|
|
-dist.doc.path=doc/
|
|
+#lib.swt.jni=lib/
|
|
+#lib.swt.jar=lib/swt.jar
|
|
+#lib.itext.jar=lib/itext.jar
|
|
+#dist.file=xml/build-linux.xml
|
|
+#dist.version=1.2
|
|
+#dist.jar.path=./
|
|
+#dist.bin.path=./
|
|
+#dist.share.path=share/
|
|
+#dist.doc.path=doc/
|
|
|
|
########## UBUNTU BUILD PROPERTIES ##########
|
|
#lib.swt.jni=/usr/lib/jni/
|
|
@@ -29,15 +29,15 @@
|
|
#dist.doc.path=${dist.prefix}/share/doc/tuxguitar/
|
|
|
|
########## FREEBSD BUILD PROPERTIES ##########
|
|
-#lib.swt.jni=/usr/local/lib/
|
|
-#lib.swt.jar=/usr/local/share/java/classes/swt.jar
|
|
-#lib.itext.jar=/usr/local/share/java/classes/itext.jar
|
|
-#dist.file=xml/build-freebsd.xml
|
|
-#dist.version=1.2
|
|
-#dist.jar.path=/usr/local/share/java/TuxGuitar-${dist.version}/
|
|
-#dist.bin.path=/usr/local/bin/
|
|
-#dist.share.path=/usr/local/share/TuxGuitar-${dist.version}/
|
|
-#dist.doc.path=/usr/local/share/doc/TuxGuitar-${dist.version}/
|
|
+lib.swt.jni=%%LOCALBASE%%/lib/
|
|
+lib.swt.jar=%%JAVAJARDIR%%/swt-devel.jar
|
|
+lib.itext.jar=%%JAVAJARDIR%%/itext.jar
|
|
+dist.file=xml/build-freebsd.xml
|
|
+dist.version=1.2
|
|
+dist.jar.path=%%JAVASHAREDIR%%/TuxGuitar-${dist.version}/
|
|
+dist.bin.path=%%PREFIX%%/bin
|
|
+dist.share.path=%%DATADIR%%
|
|
+dist.doc.path=%%DOCSDIR%%
|
|
|
|
########## DEFAULT MAC BUILD PROPERTIES ##########
|
|
#lib.swt.jni=lib/
|
|
@@ -62,4 +62,4 @@
|
|
#dist.doc.path=doc\\
|
|
## get JanelWindows.exe from http://sourceforge.net/projects/janel/
|
|
#janel.exe=utilities\\tuxguitar.exe
|
|
-#janel.lap.prefix=${FOUND_EXE_FOLDER}\\
|
|
\ No newline at end of file
|
|
+#janel.lap.prefix=${FOUND_EXE_FOLDER}\\
|