mirror of
https://git.freebsd.org/ports.git
synced 2025-05-01 02:56:39 -04:00
Seems like the compiler got a whole lot stricter with this release. The biggest fix was changing the thread ID from unsigned long to pthread_t, which will probably break compilation on Win32. While we are at it, replace static uses of REINPLACE_CMD with patch files as per policy. This change is responsible for most of the newly added patches. The wzdftpd build scripts want to install plugins into ${PREFIX}/share when they belong into ${PREFIX}/lib. Instead of patching this in each Makefile.am, set --datadir=${PREFIX}/lib and work around the one file for which this is wrong. Approved by: eduardo (mentor) Differential Revision: https://reviews.freebsd.org/D38523
11 lines
354 B
C
11 lines
354 B
C
--- modules/sfv/libwzd_sfv_main.h.orig 2006-05-29 16:45:55 UTC
|
|
+++ modules/sfv/libwzd_sfv_main.h
|
|
@@ -15,7 +15,7 @@ typedef struct {
|
|
double size_total;
|
|
} wzd_release_stats;
|
|
|
|
-wzd_sfv_config SfvConfig; /*Our main SFV config */
|
|
+extern wzd_sfv_config SfvConfig; /*Our main SFV config */
|
|
char * create_filepath(const char *dir, const char * file);
|
|
|
|
|