mirror of
https://git.freebsd.org/ports.git
synced 2025-04-30 18:46:38 -04:00
Seems like the compiler got a whole lot stricter with this release. The biggest fix was changing the thread ID from unsigned long to pthread_t, which will probably break compilation on Win32. While we are at it, replace static uses of REINPLACE_CMD with patch files as per policy. This change is responsible for most of the newly added patches. The wzdftpd build scripts want to install plugins into ${PREFIX}/share when they belong into ${PREFIX}/lib. Instead of patching this in each Makefile.am, set --datadir=${PREFIX}/lib and work around the one file for which this is wrong. Approved by: eduardo (mentor) Differential Revision: https://reviews.freebsd.org/D38523
10 lines
239 B
C
10 lines
239 B
C
--- libwzd/libwzd_tls.c.orig 2006-09-19 13:28:28 UTC
|
|
+++ libwzd/libwzd_tls.c
|
|
@@ -153,7 +153,6 @@ int tls_write(const char *buffer, int length)
|
|
#elif HAVE_GNUTLS
|
|
|
|
#include <gnutls/gnutls.h>
|
|
-#include <gcrypt.h>
|
|
|
|
#define DH_BITS 1024
|
|
|