ports/ftp/wzdftpd/files/patch-libwzd-auth_wzd__md5.c
Robert Clausecker 2f04ed793d ftp/wzdftpd: fix build with LLVM 15
Seems like the compiler got a whole lot stricter with this release.
The biggest fix was changing the thread ID from unsigned long to
pthread_t, which will probably break compilation on Win32.

While we are at it, replace static uses of REINPLACE_CMD with patch
files as per policy.  This change is responsible for most of the
newly added patches.

The wzdftpd build scripts want to install plugins into ${PREFIX}/share
when they belong into ${PREFIX}/lib.  Instead of patching this in each
Makefile.am, set --datadir=${PREFIX}/lib and work around the one file
for which this is wrong.

Approved by:	eduardo (mentor)
Differential Revision: https://reviews.freebsd.org/D38523
2023-02-14 21:23:41 +01:00

11 lines
452 B
C

--- libwzd-auth/wzd_md5.c.orig 2023-02-11 10:36:30 UTC
+++ libwzd-auth/wzd_md5.c
@@ -158,7 +158,7 @@ void MD5Name(MD5Final)(unsigned char digest[16], struc
MD5Name(MD5Transform)(ctx->buf, (uint32 *) ctx->in);
byteReverse((unsigned char *) ctx->buf, 4);
memcpy(digest, ctx->buf, 16);
- memset(ctx, 0, sizeof(ctx)); /* In case it's sensitive */
+ explicit_bzero(ctx, sizeof *ctx); /* In case it's sensitive */
}
#ifndef ASM_MD5