mirror of
https://git.freebsd.org/ports.git
synced 2025-05-08 03:40:46 -04:00
The fix for bug 274108 broke running the notify-send command, resulting in: ld-elf.so.1: /usr/local/lib/libglib-2.0.so.0: Undefined symbol "environ" This is because libnotify uses the same linker version script for both its libnotify.so shared library and for its notify-send executable. The linker version script places all symbols that do not begin with "notify_" into the local scope, making them effectively hidden. This is fine for a shared library, but not for an executable, since it will also hide the symbols "environ" and "__progname", which are required for most programs. Fix it by not using the linker version script for the notify-send executable, so no required symbols are hidden. PR: 275104, 274108 MFH: 2023Q4
18 lines
577 B
Text
18 lines
577 B
Text
--- libnotify/meson.build.orig 2023-02-17 21:20:15 UTC
|
|
+++ libnotify/meson.build
|
|
@@ -46,7 +46,6 @@ notify_dep = declare_dependency(
|
|
dependencies: libnotify_deps,
|
|
compile_args: libnotify_cflags,
|
|
sources: headers + [enum_types[1]] + [marshal[1]],
|
|
- link_args: libnotify_ldflags,
|
|
)
|
|
|
|
libnotify_lib = shared_library(LIBNAME,
|
|
@@ -55,6 +54,7 @@ libnotify_lib = shared_library(LIBNAME,
|
|
version: '@0@.@1@.@2@'.format(LT_CURRENT, LT_REVISION, LT_AGE),
|
|
soversion: LT_CURRENT,
|
|
install: true,
|
|
+ link_args: libnotify_ldflags,
|
|
)
|
|
|
|
libnotify_dep = declare_dependency(
|