mirror of
https://git.freebsd.org/ports.git
synced 2025-05-01 02:56:39 -04:00
- take over maintainership of this unmaintained port - add a DOCS option - add a non-default SIMD option for adapting the binary to the CPU - patch out -Werror more thoroughly Changelog: https://github.com/openstack/liberasurecode/blob/master/ChangeLog PR: 263241
29 lines
1.9 KiB
Text
29 lines
1.9 KiB
Text
--- test/Makefile.am.orig 2022-04-08 23:59:40 UTC
|
|
+++ test/Makefile.am
|
|
@@ -5,22 +5,22 @@ test_xor_hd_code_SOURCES = \
|
|
builtin/xor_codes/test_xor_hd_code.c \
|
|
builtin/xor_codes/test_xor_hd_code.h
|
|
test_xor_hd_code_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/include/erasurecode -I$(top_srcdir)/include/xor_codes @GCOV_FLAGS@
|
|
-test_xor_hd_code_LDFLAGS = @GCOV_LDFLAGS@ -static-libtool-libs $(top_builddir)/src/liberasurecode.la $(top_builddir)/src/builtin/xor_codes/libXorcode.la -ldl
|
|
+test_xor_hd_code_LDFLAGS = @GCOV_LDFLAGS@ -static-libtool-libs $(top_builddir)/src/liberasurecode.la $(top_builddir)/src/builtin/xor_codes/libXorcode.la
|
|
check_PROGRAMS = test_xor_hd_code
|
|
|
|
alg_sig_test_SOURCES = utils/chksum/test_alg_sig.c
|
|
alg_sig_test_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/include/erasurecode -I$(top_srcdir)/include/xor_codes @GCOV_FLAGS@
|
|
-alg_sig_test_LDFLAGS = @GCOV_LDFLAGS@ -static-libtool-libs $(top_builddir)/src/liberasurecode.la -ldl
|
|
+alg_sig_test_LDFLAGS = @GCOV_LDFLAGS@ -static-libtool-libs $(top_builddir)/src/liberasurecode.la
|
|
check_PROGRAMS += alg_sig_test
|
|
|
|
liberasurecode_test_SOURCES = liberasurecode_test.c
|
|
liberasurecode_test_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/include/erasurecode @GCOV_FLAGS@
|
|
-liberasurecode_test_LDFLAGS = @GCOV_LDFLAGS@ $(top_builddir)/src/liberasurecode.la -ldl -lpthread -lz
|
|
+liberasurecode_test_LDFLAGS = @GCOV_LDFLAGS@ $(top_builddir)/src/liberasurecode.la -lpthread -lz
|
|
check_PROGRAMS += liberasurecode_test
|
|
|
|
libec_slap_SOURCES = libec_slap.c
|
|
libec_slap_CPPFLAGS = -I. -I$(top_srcdir)/include -I$(top_srcdir)/include/erasurecode @GCOV_FLAGS@
|
|
-libec_slap_LDFLAGS = @GCOV_LDFLAGS@ $(top_builddir)/src/liberasurecode.la -ldl -lpthread
|
|
+libec_slap_LDFLAGS = @GCOV_LDFLAGS@ $(top_builddir)/src/liberasurecode.la -lpthread
|
|
check_PROGRAMS += libec_slap
|
|
|
|
rs_galois_test_SOURCES = builtin/rs_vand/rs_galois_test.c
|