ports/devel/liberasurecode/files/patch-src_Makefile.am
Robert Clausecker 6dab2add28 devel/liberasurecode: exorcise -Werror more thoroughly
Looks like upstream put a few more in after I took out all of
them in the previous commit.  This fixes the build with LLVM 15,
which takes offence in declaring parameterless function as foo()
instead of foo(void).

Approved by:	eduardo (mentor)
Differential Revision: https://reviews.freebsd.org/D38524
2023-02-14 21:23:42 +01:00

11 lines
375 B
Text

--- src/Makefile.am.orig 2023-02-11 12:58:35 UTC
+++ src/Makefile.am
@@ -32,7 +32,7 @@ liberasurecode_la_SOURCES = \
backends/shss/shss.c \
backends/phazrio/libphazr.c
-liberasurecode_la_CPPFLAGS = -Werror @GCOV_FLAGS@
+liberasurecode_la_CPPFLAGS = @GCOV_FLAGS@
liberasurecode_la_LIBADD = \
builtin/null_code/libnullcode.la \
builtin/xor_codes/libXorcode.la \