ports/databases/firebird30-server/files/patch-builds_posix_Makefile.in
Muhammad Moinur Rahman 54ce503f0a databases/firebird30-*: Fix consumers build
After firebird25-* was removed from the tree firebird30-* bacem the new
default. And some consumers of firebird started failing to build with
the error "/usr/local/include/ibase.h:6:10: fatal error:
'../jrd/ibase.h' file not found".

In previous the src headers files were installed which were not
sanitized and required other header files from the source tree. This
patch properly installs the sanitized header files and fixes the
consumer builds.

While I am here fix the patches to be makepatch compatible.

Approved by:	portmgr(just-fix-it)
2023-01-01 01:43:51 +01:00

21 lines
677 B
Text

--- builds/posix/Makefile.in.orig 2022-06-07 08:18:52 UTC
+++ builds/posix/Makefile.in
@@ -191,16 +191,16 @@ master_process:
$(MAKE) preliminaryCheck
$(MAKE) boot
$(MAKE) yvalve
+ $(MAKE) engine
ifeq ($(IsDeveloper), Y)
# In developer mode we must regenerate various files in include/gen
$(MAKE) ids
endif
- $(MAKE) engine
$(MAKE) fbintl
$(MAKE) utilities
# Now having ready such useful tools as gbak and isql, we may restore / create
# required databases and switch to full-featured gpre
- $(MAKE) gpre
+ $(MAKE) gbak gfix gpre
# Pay attention - after build force gpre_current to point to gpre
# even if gpre itself was not rebuilt
-$(RM) $(GPRE_CURRENT)