mirror of
https://git.freebsd.org/ports.git
synced 2025-05-16 17:21:49 -04:00
the following features[1]: - row-major and column-major matrix layout controlled by the first function parameter; - an implementation with working arrays (middle-level interface) as well as without working arrays (high-level interface); - input scalars passed by value; - error code as a return value instead of the INFO parameter. [1] Intel Corporation. "C Interface to LAPACK" README. 2010. WWW: http://www.netlib.org/lapack/ PR: 153045 Submitted by: Eijiro Shibusawa <phd_kimberlite@yahoo.co.jp>
34 lines
807 B
Text
34 lines
807 B
Text
--- testing/interface/Makefile.orig 2010-12-06 20:30:08.000000000 +0900
|
|
+++ testing/interface/Makefile 2010-12-06 20:38:46.000000000 +0900
|
|
@@ -497,9 +497,9 @@
|
|
zupgtr_1 \
|
|
zupmtr_1
|
|
|
|
-OBJ = $(TST:%=%.o)
|
|
-EXE = $(TST:%=x%)
|
|
-OUT = $(TST:%=%.out)
|
|
+OBJ = ${TST:N*.h:R:S/$/.o/}
|
|
+EXE = ${TST}
|
|
+OUT = ${TST:N*.h:R:S/$/.out/}
|
|
|
|
AUX = ../utils/compare_complex_doubles.o \
|
|
../utils/compare_complex_floats.o \
|
|
@@ -510,14 +510,10 @@
|
|
|
|
tst: $(OUT)
|
|
|
|
-%.out : x%
|
|
- ./$< > $@
|
|
-
|
|
-x% : %.o
|
|
- $(LINKER) $(LDFLAGS) $< -o $@ $(AUX) ../../$(LAPACKE) $(LIBS)
|
|
-
|
|
-%.o : %.c
|
|
- $(CC) -c $(CFLAGS) -I ../include -I ../../include -o $@ $<
|
|
+.c.out :
|
|
+ $(CC) -c $(CFLAGS) -I ../include -I ../../include $<
|
|
+ $(LINKER) $(LDFLAGS) $*.o -o $* $(AUX) ../../$(LAPACKE) $(LIBS)
|
|
+ ./$* > $@
|
|
|
|
clean:
|
|
rm -f $(EXE) $(OBJ)
|