mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 15:36:35 -04:00
- add support for embedded php library - add support for dtrace Re-organize bsd.php.mk: - add WANT_PHP_EMD - fix handling of WANT_PHP_* - remove php4 extensions From UPDATING: Suhosin patch has been disabled until the new version will be released (soon). Suhosing extension will take more time. LINKTHR option is now enabled by default, be sure to flag it if you are updating using an old saved configuration. sqlite2 extension has been permanently removed. If you want to remain at PHP 5.3, a new port (lang/php53) will be committed soon.
56 lines
2.1 KiB
C
56 lines
2.1 KiB
C
--- soap.c.orig 2012-03-02 15:46:04.000000000 +0100
|
|
+++ soap.c 2012-03-02 15:45:38.000000000 +0100
|
|
@@ -23,7 +23,7 @@
|
|
#include "config.h"
|
|
#endif
|
|
#include "php_soap.h"
|
|
-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
|
|
+#if HAVE_PHP_SESSION
|
|
#include "ext/session/php_session.h"
|
|
#endif
|
|
#include "zend_exceptions.h"
|
|
@@ -1639,7 +1639,7 @@
|
|
soap_obj = service->soap_object;
|
|
function_table = &((Z_OBJCE_P(soap_obj))->function_table);
|
|
} else if (service->type == SOAP_CLASS) {
|
|
-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
|
|
+#if HAVE_PHP_SESSION
|
|
/* If persistent then set soap_obj from from the previous created session (if available) */
|
|
if (service->soap_class.persistance == SOAP_PERSISTENCE_SESSION) {
|
|
zval **tmp_soap;
|
|
@@ -1722,7 +1722,7 @@
|
|
}
|
|
efree(class_name);
|
|
}
|
|
-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
|
|
+#if HAVE_PHP_SESSION
|
|
/* If session then update session hash with new object */
|
|
if (service->soap_class.persistance == SOAP_PERSISTENCE_SESSION) {
|
|
zval **tmp_soap_pp;
|
|
@@ -1820,7 +1820,7 @@
|
|
if (service->type == SOAP_CLASS || service->type == SOAP_OBJECT) {
|
|
call_status = call_user_function(NULL, &soap_obj, &function_name, retval, num_params, params TSRMLS_CC);
|
|
if (service->type == SOAP_CLASS) {
|
|
-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
|
|
+#if HAVE_PHP_SESSION
|
|
if (service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
|
|
zval_ptr_dtor(&soap_obj);
|
|
soap_obj = NULL;
|
|
@@ -1845,7 +1845,7 @@
|
|
soap_server_fault_ex(function, EG(exception), NULL TSRMLS_CC);
|
|
}
|
|
if (service->type == SOAP_CLASS) {
|
|
-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
|
|
+#if HAVE_PHP_SESSION
|
|
if (soap_obj && service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
|
|
#else
|
|
if (soap_obj) {
|
|
@@ -1887,7 +1887,7 @@
|
|
soap_server_fault_ex(function, EG(exception), NULL TSRMLS_CC);
|
|
}
|
|
if (service->type == SOAP_CLASS) {
|
|
-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
|
|
+#if HAVE_PHP_SESSION
|
|
if (soap_obj && service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
|
|
#else
|
|
if (soap_obj) {
|