mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
<ChangeLog> *) Bugfix: fix instability issues due to OpenTelemetry (OTEL) support. *) Bugfix: fix issues with building OpenTelemetry (OTEL) support on various platforms, including macOS. </ChangeLog>
34 lines
834 B
Makefile
34 lines
834 B
Makefile
PKGNAMESUFFIX= -${UNIT_MODNAME}
|
|
|
|
UNIT_MODNAME= wasm
|
|
|
|
COMMENT= WASM module for NGINX Unit
|
|
|
|
PLIST_FILES= libexec/unit/modules/${UNIT_MODNAME}.unit.so
|
|
|
|
RUN_DEPENDS= unitd:www/unit
|
|
|
|
LIB_DEPENDS= libwasmtime.so:devel/libwasmtime
|
|
|
|
USE_RC_SUBR?= # reset to empty
|
|
|
|
MASTERDIR= ${.CURDIR}/../unit
|
|
|
|
post-configure:
|
|
cd ${CONFIGURE_WRKSRC} && \
|
|
${SETENV} ${CONFIGURE_ENV} ${CONFIGURE_CMD} wasm \
|
|
--module=${UNIT_MODNAME} \
|
|
--include-path=${PREFIX}/include \
|
|
--lib-path=${PREFIX}/lib
|
|
|
|
do-build:
|
|
cd ${CONFIGURE_WRKSRC} && \
|
|
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
|
|
${MAKEFILE} ${MAKE_ARGS} ${UNIT_MODNAME}
|
|
|
|
do-install:
|
|
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/unit/modules/
|
|
${INSTALL_LIB} ${WRKSRC}/build/lib/unit/modules/${UNIT_MODNAME}.unit.so \
|
|
${STAGEDIR}${PREFIX}/libexec/unit/modules/
|
|
|
|
.include "${MASTERDIR}/Makefile"
|