mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
Most USES use a colon for build/run(/test) suffixes. Change kde.mk, qt.mk and pyqt.mk to do the same, and update all ports using that. Document in CHANGES. PR: 266034 Exp-run by: antoine Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D36349
18 lines
517 B
Makefile
18 lines
517 B
Makefile
PORTNAME= webglplugin
|
|
PORTVERSION= ${QT5_VERSION}${QT5_KDE_PATCH}
|
|
CATEGORIES= www
|
|
PKGNAMEPREFIX= qt5-
|
|
|
|
MAINTAINER= kde@FreeBSD.org
|
|
COMMENT= Qt QPA plugin for running an application via a browser using streamed WebGL commands
|
|
|
|
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
|
|
libfreetype.so:print/freetype2
|
|
|
|
USES= compiler:c++11-lang gl gnome qmake:norecursive qt-dist:5
|
|
USE_GL= gl
|
|
USE_GNOME= glib20
|
|
USE_QT= core dbus declarative gui network webchannel websockets \
|
|
buildtools:build
|
|
|
|
.include <bsd.port.mk>
|