mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
- Convert to USE_PYTHON=pep517 Changes: https://github.com/requests/requests-oauthlib/blob/master/HISTORY.rst
26 lines
874 B
Makefile
26 lines
874 B
Makefile
PORTNAME= requests-oauthlib
|
|
PORTVERSION= 2.0.0
|
|
CATEGORIES= www python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= sunpoet@FreeBSD.org
|
|
COMMENT= OAuthlib authentication support for Requests
|
|
WWW= https://github.com/requests/requests-oauthlib
|
|
|
|
LICENSE= ISCL
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}oauthlib>=3.0.0:security/py-oauthlib@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}requests>=2.0.0:www/py-requests@${PY_FLAVOR}
|
|
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}requests-mock>=0:www/py-requests-mock@${PY_FLAVOR}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist concurrent pep517 unittest
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|