mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
PyQt5: - devel/py-qt5-pyqt: Update to 5.15.11 - graphics/py-qt5-3d: Add port - net/py-qt5-networkauth: Update to 5.15.6 - www/py-qt5-webengine: Update to 5.15.7 - x11-toolkits/py-qt5-chart: Update to 5.15.7 - x11-toolkits/py-qt5-datavis3d: Add port PyQt6: - devel/py-qt6-pyqt: Update to 6.7.1 Build tools: - devel/sip: Update to 6.8.6 - devel/py-qt5-sip: Update to 12.15.0 - devel/py-qt6-sip: Update to 13.8.0 - devel/py-qtbuilder: Update to 1.16.4 The build tools are now all licensed BSD2CLAUSE and have been converted to PEP517.
27 lines
784 B
Makefile
27 lines
784 B
Makefile
PORTNAME= webengine
|
|
DISTVERSION= ${PYQTWEBENGINE_VERSION}
|
|
CATEGORIES= www devel python
|
|
MASTER_SITES= ${MASTER_SITES_PYQTWEBENGINE}
|
|
PKGNAMEPREFIX= ${PYQT_PY_RELNAME}-
|
|
DISTNAME= ${PYQTWEBENGINE_DISTNAME}
|
|
|
|
MAINTAINER= kde@FreeBSD.org
|
|
COMMENT= Python bindings for the Qt5 toolkit, QtWebEngine module
|
|
WWW= https://riverbankcomputing.com/software/pyqt
|
|
|
|
LICENSE= ${PYQT5_LICENSE}
|
|
|
|
USES= gl pyqt:5,dist python qt:5
|
|
USE_GL= gl
|
|
USE_PYQT= pyqt5 qtbuilder:build sip:build
|
|
USE_PYTHON= concurrent flavors
|
|
USE_QT= core declarative gui location network printsupport webchannel \
|
|
webengine widgets qmake:build
|
|
|
|
PLIST_SUB= PYQT_WEBENGINE_VERSION=${DISTVERSION}
|
|
|
|
post-install:
|
|
@${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5 \
|
|
-name '*.so*' -exec ${STRIP_CMD} {} +
|
|
|
|
.include <bsd.port.mk>
|