ports/www/py-google-api-python-client/Makefile
Nicola Vitale 5e2963abdd
www/py-google-api-python-client: Update to 2.167.0
Release changes:	https://github.com/googleapis/google-api-python-client/releases/tag/v2.167.0
Reported by:	"release-please[bot]" <notifications@github.com>
2025-04-15 10:58:04 +02:00

51 lines
2.5 KiB
Makefile

PORTNAME= google-api-python-client
DISTVERSION= 2.167.0
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME:S/-/_/g}-${DISTVERSIONFULL}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Google API Client Library for Python
WWW= https://github.com/googleapis/google-api-python-client
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-api-core>=1.31.5:www/py-google-api-core@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}google-auth-httplib2>=0.2.0:security/py-google-auth-httplib2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}google-auth>=1.32:security/py-google-auth@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}httplib2>=0.19.0:www/py-httplib2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}uritemplate>=3.0.1:net/py-uritemplate@${PY_FLAVOR}
# tests: 317 passed, 4 deselected
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-api-core>=1.31.5:www/py-google-api-core@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}google-auth-httplib2>=0.2.0:security/py-google-auth-httplib2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}google-auth>=1.32:security/py-google-auth@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}httplib2>=0.19.0:www/py-httplib2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}oauth2client>=4.1.3:security/py-oauth2client@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}parameterized>=0.8.1:devel/py-parameterized@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}uritemplate>=3.0.1:net/py-uritemplate@${PY_FLAVOR}
# We don't want to use Pytest plugins, for example devel/py-ruff, if available in the system
TEST_ENV= PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
USES= pytest python
USE_PYTHON= autoplist distutils pytest
# Require Application Default Credentials
# see https://cloud.google.com/docs/authentication/external/set-up-adc
PYTEST_IGNORED_TESTS= test_universe_env_var_configured_with_mtls \
test_client_options_universe_configured_with_mtls \
test_tests_should_be_run_with_strict_positional_enforcement
# Requires oauth2client < 4.0.0 to pass
# tests/test_discovery_cache.py:34: FileCache unavailable.
# ModuleNotFoundError: No module named oauth2client.contrib.locked_file
# ImportError: file_cache is unavailable when using oauth2client >= 4.0.0 or google-auth
PYTEST_IGNORED_TESTS+= test_discovery_cache.py
NO_ARCH= yes
OPTIONS_DEFINE= WEBTEST
WEBTEST_DESC= Use WebTest helper to test WSGI apps
WEBTEST_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}webtest>0:www/py-webtest@${PY_FLAVOR}
.include <bsd.port.mk>