mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
31 lines
754 B
Makefile
31 lines
754 B
Makefile
PORTNAME= Flask-Sphinx-Themes
|
|
DISTVERSION= 1.0.2
|
|
CATEGORIES= www python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= matthew@wener.org
|
|
COMMENT= Sphinx themes for Flask and related projects
|
|
WWW= https://github.com/pallets/flask-sphinx-themes
|
|
|
|
LICENSE= BSD2CLAUSE
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
BUILD_DEPENDS= ${PY_SETUPTOOLS} \
|
|
${PYTHON_PKGNAMEPREFIX}wheel>=:devel/py-wheel@${PY_FLAVOR}
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist pep517
|
|
|
|
NO_ARCH= yes
|
|
|
|
PORTDOCS= PKG-INFO README.rst
|
|
|
|
OPTIONS_DEFINE= DOCS
|
|
|
|
post-install-DOCS-on:
|
|
@${MKDIR} ${STAGEDIR}${DOCSDIR}/
|
|
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
|
|
|
|
.include <bsd.port.mk>
|