mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
Changes: https://github.com/miguelgrinberg/Flask-SocketIO/releases https://github.com/miguelgrinberg/Flask-SocketIO/blob/main/CHANGES.md
25 lines
761 B
Makefile
25 lines
761 B
Makefile
PORTNAME= flask-socketio
|
|
PORTVERSION= 5.5.1
|
|
CATEGORIES= www python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
DISTNAME= flask_socketio-${PORTVERSION}
|
|
|
|
MAINTAINER= sunpoet@FreeBSD.org
|
|
COMMENT= Socket.IO integration for Flask applications
|
|
WWW= https://github.com/miguelgrinberg/Flask-SocketIO
|
|
|
|
LICENSE= MIT
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61.2:devel/py-setuptools@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flask>=0.9:www/py-flask@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}python-socketio>=5.12.0:devel/py-python-socketio@${PY_FLAVOR}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist concurrent pep517
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|