mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
26 lines
711 B
Makefile
26 lines
711 B
Makefile
PORTNAME= flask-script
|
|
PORTVERSION= 2.0.6
|
|
PORTREVISION= 1
|
|
CATEGORIES= www python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
DISTNAME= Flask-Script-${PORTVERSION}
|
|
|
|
MAINTAINER= sunpoet@FreeBSD.org
|
|
COMMENT= Scripting support for Flask
|
|
WWW= https://flask-script.readthedocs.io/en/latest/ \
|
|
https://github.com/smurfix/flask-script
|
|
|
|
LICENSE= BSD3CLAUSE
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flask>=0:www/py-flask@${PY_FLAVOR}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist concurrent pep517
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|