mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Any missed ports, feel free to bump. Any ports that need setuptools at runtime can have the devel/py-setuptools manually added back to RUN_DEPENDS, but understand that this practice is deprecated; see CHANGES for details.
24 lines
586 B
Makefile
24 lines
586 B
Makefile
PORTNAME= flask-caching
|
|
PORTVERSION= 2.2.0
|
|
PORTREVISION= 1
|
|
CATEGORIES= www python
|
|
MASTER_SITES= PYPI
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
DISTNAME= flask_caching-${PORTVERSION}
|
|
|
|
MAINTAINER= acm@FreeBSD.org
|
|
COMMENT= Flask-Caching is an extension to Flask
|
|
WWW= https://github.com/pallets-eco/flask-caching
|
|
|
|
LICENSE= BSD3CLAUSE
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flask>=0.8:www/py-flask@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}cachelib>0:www/py-cachelib@${PY_FLAVOR}
|
|
|
|
USES= python
|
|
USE_PYTHON= autoplist distutils
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|