ports/www/py-django-tables2/Makefile
Kai Knoblich 5ad476659d www/py-django-tables2: Update to 2.7.5
* Support for Python 3.8 was dropped with the 2.7.1 release, adjust
  USES=python accordingly.

* Switch to the PEP517 build framework.

Changelog since 2.7.0:

https://github.com/jieter/django-tables2/blob/v2.7.5/CHANGELOG.md
2025-01-07 20:11:47 +01:00

30 lines
815 B
Makefile

PORTNAME= django-tables2
DISTVERSION= 2.7.5
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= django_tables2-${DISTVERSION}
MAINTAINER= kai@FreeBSD.org
COMMENT= Table/data-grid framework for Django
WWW= https://github.com/jieter/django-tables2
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>0:devel/py-hatchling@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django42>=4.2:www/py-django42@${PY_FLAVOR}
USES= python:3.9+
USE_PYTHON= autoplist pep517
CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}*${PORTNAME}
NO_ARCH= yes
OPTIONS_DEFINE= TABLIB
TABLIB_DESC= Enable support for exporting table datasets
TABLIB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tablib>=0:textproc/py-tablib@${PY_FLAVOR}
.include <bsd.port.mk>